Browse Source

macchanger: import from old packages feed

 - update to latest version (v1.7.0)
 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 9 years ago
parent
commit
548c85a5f9
1 changed files with 45 additions and 0 deletions
  1. 45
    0
      utils/macchanger/Makefile

+ 45
- 0
utils/macchanger/Makefile View File

@@ -0,0 +1,45 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=macchanger
11
+PKG_VERSION:=1.7.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=https://github.com/alobbs/macchanger/releases/download/$(PKG_VERSION)/
16
+PKG_MD5SUM:=ca56f16142914337391dac91603eb332
17
+
18
+PKG_LICENSE:=GPL-2.0+
19
+PKG_LICENSE_FILES:=COPYING
20
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
21
+
22
+PKG_INSTALL:=1
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/macchanger
27
+  SECTION:=utils
28
+  CATEGORY:=Utilities
29
+  TITLE:=utility for viewing/manipulating the MAC address
30
+  URL:=https://github.com/alobbs/macchanger/
31
+endef
32
+
33
+define Package/macchanger/description
34
+	This is a GNU/Linux utility for viewing/manipulating the MAC address
35
+	of network interfaces.
36
+endef
37
+
38
+define Package/macchanger/install
39
+	$(INSTALL_DIR) $(1)/usr/bin
40
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/macchanger $(1)/usr/bin/
41
+	$(INSTALL_DIR) $(1)/usr/share
42
+	$(CP) $(PKG_INSTALL_DIR)/usr/share/macchanger $(1)/usr/share/
43
+endef
44
+
45
+$(eval $(call BuildPackage,macchanger))