Browse Source

bwm-ng: fix building with gcc-security enabled

Julen Landa Alustiza 9 years ago
parent
commit
5aae478e24
2 changed files with 13 additions and 2 deletions
  1. 2
    2
      net/bwm-ng/Makefile
  2. 11
    0
      net/bwm-ng/patches/0001-fix-gcc-security-build.patch

+ 2
- 2
net/bwm-ng/Makefile View File

@@ -1,12 +1,12 @@
1 1
 #
2
-# Copyright (C) 2014 OpenWrt.org
2
+# Copyright (C) 2014-2015 OpenWrt.org
3 3
 #
4 4
 
5 5
 include $(TOPDIR)/rules.mk
6 6
 
7 7
 PKG_NAME:=bwm-ng
8 8
 PKG_VERSION:=0.6
9
-PKG_RELEASE:=1
9
+PKG_RELEASE:=2
10 10
 
11 11
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
12 12
 PKG_SOURCE_URL:=http://www.gropp.org/bwm-ng

+ 11
- 0
net/bwm-ng/patches/0001-fix-gcc-security-build.patch View File

@@ -0,0 +1,11 @@
1
+--- a/src/output.c
2
++++ b/src/output.c
3
+@@ -234,7 +234,7 @@ int print_header(int option) {
4
+ 			if (output_method==PLAIN_OUT && ansi_output) printf("\033[1;2H");
5
+ 	        printf("bwm-ng v" VERSION " (delay %2.3fs); ",(float)delay/1000);
6
+ 			if (output_method==PLAIN_OUT) printf("press 'ctrl-c' to end this%s",(ansi_output ? "\033[2;2H" : "")); else printf("input: ");
7
+-            printf(input2str());
8
++            printf("%s\n",input2str());
9
+             printf("%s\n",show_all_if2str());
10
+ 			if (output_method==PLAIN_OUT) {
11
+ 				if (ansi_output)