Explorar el Código

gnunet: build PostgreSQL and mySQL backends

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle hace 9 años
padre
commit
60ba8483f1
Se han modificado 1 ficheros con 29 adiciones y 16 borrados
  1. 29
    16
      net/gnunet/Makefile

+ 29
- 16
net/gnunet/Makefile Ver fichero

@@ -10,14 +10,13 @@ include $(TOPDIR)/rules.mk
10 10
 PKG_NAME:=gnunet
11 11
 PKG_SOURCE_VERSION:=35963
12 12
 PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
13
-PKG_RELEASE:=1
13
+PKG_RELEASE:=2
14 14
 
15 15
 # ToDo:
16 16
 #  - break-out transports
17 17
 #    -> get rid of microhttpd and gnurl dependency for gns and vpn
18 18
 #       requires upstream to split config files
19
-#  - break-out {peer,name,data}store
20
-#  - building and package mysql or postgresql storage backends
19
+#  - break-out {peer,name,data}store for each backend
21 20
 #  - package testing stuff
22 21
 
23 22
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -36,15 +35,15 @@ PKG_INSTALL:=1
36 35
 include $(INCLUDE_DIR)/package.mk
37 36
 
38 37
 CONFIGURE_ARGS+= \
39
-	--disable-rpath \
38
+	--with-ltdl \
39
+	$(if $(CONFIG_PACKAGE_$(PKG_NAME)-mysql),--with-mysql="$(STAGING_DIR)/usr",--without-mysql) \
40
+	$(if $(CONFIG_PACKAGE_$(PKG_NAME)-pgsql),--with-postgresql="$(STAGING_DIR)/usr/bin/pg_config",--without-postgresql) \
41
+	$(if $(CONFIG_PACKAGE_$(PKG_NAME)-sqlite),--with-sqlite="$(STAGING_DIR)/usr",--without-sqlite) \
40 42
 	--with-extractor=$(STAGING_DIR)/usr \
41 43
 	--with-gnutls=$(STAGING_DIR)/usr \
42 44
 	--with-libgnurl=$(STAGING_DIR)/usr \
43 45
 	--with-libunistring-prefix=$(STAGING_DIR)/usr \
44
-	--with-ltdl \
45
-	--with-microhttpd=$(STAGING_DIR)/usr \
46
-	--without-mysql \
47
-	--without-postgresql
46
+	--with-microhttpd=$(STAGING_DIR)/usr
48 47
 
49 48
 # ToDo: request upstream to provide --with-pulseaudio=...
50 49
 TARGET_LDFLAGS+= -Wl,-rpath-link=$(STAGING_DIR)/usr/lib/pulseaudio
@@ -189,7 +188,7 @@ CONF_conversation:=conversation
189 188
 DEPENDS_experiments:=+libglpk
190 189
 PLUGIN_experiments:=ats_mlp ats_ril
191 190
 
192
-DEPENDS_fs:=+gnunet-storage +libextractor
191
+DEPENDS_fs:=+gnunet-datastore +libextractor
193 192
 BIN_fs:=auto-share directory download download-manager.scm fs publish unindex search
194 193
 LIB_fs:=fs
195 194
 PLUGIN_fs:=block_fs
@@ -204,12 +203,23 @@ PLUGIN_gns:=block_dns block_gns gnsrecord_dns gnsrecord_gns
204 203
 LIBEXEC_gns:=dns2gns gns-proxy helper-dns namestore-fcfsd service-dns service-gns service-namecache service-namestore service-resolver
205 204
 CONF_gns:=dns gns namecache namestore resolver
206 205
 
207
-DEPENDS_storage:=+gnunet-gns +libsqlite3
208
-BIN_storage:=datastore
209
-LIB_storage:=datastore
210
-PLUGIN_storage:=datacache_sqlite datastore_heap datastore_sqlite namecache_sqlite namestore_sqlite peerstore_sqlite
211
-LIBEXEC_storage:=daemon-latency-logger service-datastore
212
-CONF_storage:=datastore
206
+DEPENDS_datastore:=+gnunet-gns +libsqlite3
207
+BIN_datastore:=datastore
208
+LIB_datastore:=datastore
209
+PLUGIN_datastore:=datacache_sqlite datastore_heap datastore_sqlite namecache_sqlite namestore_sqlite peerstore_sqlite
210
+LIBEXEC_datastore:=daemon-latency-logger service-datastore
211
+CONF_datastore:=datastore
212
+
213
+DEPENDS_mysql:=+gnunet-gns +gnunet-datastore +libmysqlclient
214
+LIB_mysql:=mysql
215
+PLUGIN_mysql:=datastore_mysql
216
+
217
+DEPENDS_pgsql:=+gnunet-gns +gnunet-datastore +libpq
218
+LIB_pgsql:=postgres
219
+PLUGIN_pgsql:=datacache_postgres datastore_postgres namecache_postgres namestore_postgres
220
+
221
+DEPENDS_sqlite:=+gnunet-gns +gnunet-datastore +libsqlite3
222
+PLUGIN_sqlite:=datacache_sqlite datastore_sqlite namecache_sqlite namestore_sqlite peerstore_sqlite
213 223
 
214 224
 DEPENDS_transport-bluetooth:=+bluez-libs
215 225
 PLUGIN_transport-bluetooth:=transport_bluetooth
@@ -228,7 +238,10 @@ $(eval $(call BuildComponent,conversation,conversation component,))
228 238
 $(eval $(call BuildComponent,experiments,experimental components,))
229 239
 $(eval $(call BuildComponent,fs,file-sharing components,))
230 240
 $(eval $(call BuildComponent,gns,name resolution components,y))
231
-$(eval $(call BuildComponent,storage,storage components,))
241
+$(eval $(call BuildComponent,datastore,storage components,))
232 242
 $(eval $(call BuildComponent,transport-bluetooth,bluetooth transport,))
233 243
 $(eval $(call BuildComponent,utils,administration utililties,))
234 244
 $(eval $(call BuildComponent,vpn,vpn components,y))
245
+$(eval $(call BuildComponent,mysql,mySQL datastore backend,))
246
+$(eval $(call BuildComponent,pgsql,PostgreSQL backends,))
247
+$(eval $(call BuildComponent,sqlite,libsqlite3 backends,y))