Quellcode durchsuchen

Import and update p910nd package

Signed-off-by: Philipp Kerling <pkerling@casix.org>
Philipp Kerling vor 10 Jahren
Ursprung
Commit
64019e46d6
3 geänderte Dateien mit 115 neuen und 0 gelöschten Zeilen
  1. 59
    0
      net/p910nd/Makefile
  2. 5
    0
      net/p910nd/files/p910nd.config
  3. 51
    0
      net/p910nd/files/p910nd.init

+ 59
- 0
net/p910nd/Makefile Datei anzeigen

@@ -0,0 +1,59 @@
1
+#
2
+# Copyright (C) 2009-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=p910nd
11
+PKG_VERSION:=0.97
12
+PKG_RELEASE:=4
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
+PKG_SOURCE_URL:=@SF/p910nd
16
+PKG_LICENSE:=GPLv2
17
+PKG_LICENSE_FILES:=COPYING
18
+PKG_MD5SUM:=69461a6c54dca0b13ecad5b83864b43e
19
+PKG_MAINTAINER:=Philipp Kerling <pkerling@casix.org>
20
+
21
+PKG_INSTALL:=1
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+
25
+define Package/p910nd
26
+  SECTION:=net
27
+  CATEGORY:=Network
28
+  SUBMENU:=Printing
29
+  TITLE:=A small non-spooling printer server
30
+  URL:=http://p910nd.sourceforge.net
31
+endef
32
+
33
+define Package/p910nd/conffiles
34
+/etc/config/p910nd
35
+endef
36
+
37
+define Package/p910nd/description
38
+ p910nd is a small daemon that copies any data received on
39
+ the port it is listening on to the corresponding printer
40
+ port. It is primarily intended for diskless Linux hosts
41
+ running as printer drivers but there is no reason why it
42
+ could not be used on diskful hosts. Port 9100 is copied
43
+ to /dev/lp0, 9101 to /dev/lp1 and 9102 to /dev/lp2. The
44
+ default is port 9100 to /dev/lp0.
45
+endef
46
+
47
+MAKE_FLAGS += \
48
+	CFLAGS="$(TARGET_CFLAGS) -DLOCKFILE_DIR=\"\\\"/tmp\"\\\""
49
+
50
+define Package/p910nd/install
51
+	$(INSTALL_DIR) $(1)/usr/sbin
52
+	$(CP) $(PKG_INSTALL_DIR)/usr/sbin/p910nd $(1)/usr/sbin/
53
+	$(INSTALL_DIR) $(1)/etc/config
54
+	$(INSTALL_DATA) ./files/p910nd.config $(1)/etc/config/p910nd
55
+	$(INSTALL_DIR) $(1)/etc/init.d
56
+	$(INSTALL_BIN) ./files/p910nd.init $(1)/etc/init.d/p910nd
57
+endef
58
+
59
+$(eval $(call BuildPackage,p910nd))

+ 5
- 0
net/p910nd/files/p910nd.config Datei anzeigen

@@ -0,0 +1,5 @@
1
+config p910nd
2
+	option device        /dev/usb/lp0
3
+	option port          0
4
+	option bidirectional 1
5
+	option enabled       0

+ 51
- 0
net/p910nd/files/p910nd.init Datei anzeigen

@@ -0,0 +1,51 @@
1
+#!/bin/sh /etc/rc.common
2
+# Copyright (C) 2007 OpenWrt.org
3
+START=50
4
+
5
+append_bool() {
6
+	local section="$1"
7
+	local option="$2"
8
+	local value="$3"
9
+	local _val
10
+	config_get_bool _val "$section" "$option" '0'
11
+	[ "$_val" -gt 0 ] && append args "$3"
12
+}
13
+
14
+append_string() {
15
+	local section="$1"
16
+	local option="$2"
17
+	local value="$3"
18
+	local _val
19
+	config_get _val "$section" "$option"
20
+	[ -n "$_val" ] && append args "$3$_val"
21
+}
22
+
23
+start_service() {
24
+	local section="$1"
25
+	args=""
26
+
27
+	append_bool "$section" bidirectional "-b"
28
+	append_string "$section" device "-f "
29
+	append_string "$section" bind "-i "
30
+	append_string "$section" port ""
31
+	config_get_bool "enabled" "$section" "enabled" '1'
32
+	[ "$enabled" -gt 0 ] && /usr/sbin/p910nd $args
33
+}
34
+
35
+stop_service() {
36
+	local section="$1"
37
+	config_get port "$section" port
38
+
39
+	PID_F=/var/run/p910${port}d.pid
40
+	[ -f $PID_F ] && kill $(cat $PID_F)
41
+}
42
+
43
+start() {
44
+	config_load "p910nd"
45
+	config_foreach start_service p910nd
46
+}
47
+
48
+stop() {
49
+	config_load "p910nd"
50
+	config_foreach stop_service p910nd
51
+}