|
@@ -0,0 +1,59 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2009-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=p910nd
|
|
11
|
+PKG_VERSION:=0.97
|
|
12
|
+PKG_RELEASE:=4
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_URL:=@SF/p910nd
|
|
16
|
+PKG_LICENSE:=GPLv2
|
|
17
|
+PKG_LICENSE_FILES:=COPYING
|
|
18
|
+PKG_MD5SUM:=69461a6c54dca0b13ecad5b83864b43e
|
|
19
|
+PKG_MAINTAINER:=Philipp Kerling <pkerling@casix.org>
|
|
20
|
+
|
|
21
|
+PKG_INSTALL:=1
|
|
22
|
+
|
|
23
|
+include $(INCLUDE_DIR)/package.mk
|
|
24
|
+
|
|
25
|
+define Package/p910nd
|
|
26
|
+ SECTION:=net
|
|
27
|
+ CATEGORY:=Network
|
|
28
|
+ SUBMENU:=Printing
|
|
29
|
+ TITLE:=A small non-spooling printer server
|
|
30
|
+ URL:=http://p910nd.sourceforge.net
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+define Package/p910nd/conffiles
|
|
34
|
+/etc/config/p910nd
|
|
35
|
+endef
|
|
36
|
+
|
|
37
|
+define Package/p910nd/description
|
|
38
|
+ p910nd is a small daemon that copies any data received on
|
|
39
|
+ the port it is listening on to the corresponding printer
|
|
40
|
+ port. It is primarily intended for diskless Linux hosts
|
|
41
|
+ running as printer drivers but there is no reason why it
|
|
42
|
+ could not be used on diskful hosts. Port 9100 is copied
|
|
43
|
+ to /dev/lp0, 9101 to /dev/lp1 and 9102 to /dev/lp2. The
|
|
44
|
+ default is port 9100 to /dev/lp0.
|
|
45
|
+endef
|
|
46
|
+
|
|
47
|
+MAKE_FLAGS += \
|
|
48
|
+ CFLAGS="$(TARGET_CFLAGS) -DLOCKFILE_DIR=\"\\\"/tmp\"\\\""
|
|
49
|
+
|
|
50
|
+define Package/p910nd/install
|
|
51
|
+ $(INSTALL_DIR) $(1)/usr/sbin
|
|
52
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/p910nd $(1)/usr/sbin/
|
|
53
|
+ $(INSTALL_DIR) $(1)/etc/config
|
|
54
|
+ $(INSTALL_DATA) ./files/p910nd.config $(1)/etc/config/p910nd
|
|
55
|
+ $(INSTALL_DIR) $(1)/etc/init.d
|
|
56
|
+ $(INSTALL_BIN) ./files/p910nd.init $(1)/etc/init.d/p910nd
|
|
57
|
+endef
|
|
58
|
+
|
|
59
|
+$(eval $(call BuildPackage,p910nd))
|