|
@@ -0,0 +1,46 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=ncdu
|
|
11
|
+PKG_VERSION:=1.10
|
|
12
|
+PKG_RELEASE=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=http://dev.yorhel.nl/download
|
|
16
|
+PKG_MD5SUM:=7535decc8d54eca811493e82d4bfab2d
|
|
17
|
+
|
|
18
|
+PKG_INSTALL:=1
|
|
19
|
+
|
|
20
|
+PKG_LICENSE:=MIT
|
|
21
|
+PKG_LICENSE_FILES:=COPYING
|
|
22
|
+
|
|
23
|
+include $(INCLUDE_DIR)/package.mk
|
|
24
|
+
|
|
25
|
+define Package/ncdu
|
|
26
|
+ SUBMENU:=Filesystem
|
|
27
|
+ SECTION:=utils
|
|
28
|
+ CATEGORY:=Utilities
|
|
29
|
+ DEPENDS:=+libncursesw
|
|
30
|
+ TITLE:=ncurses disk usage viewer
|
|
31
|
+ MAINTAINER:=Charles Lehner <celehner1@gmail.com>
|
|
32
|
+ URL:=http://dev.yorhel.nl/ncdu
|
|
33
|
+endef
|
|
34
|
+
|
|
35
|
+define Package/ncdu/description
|
|
36
|
+ Ncdu is a ncurses-based du viewer. It provides a fast and easy-to-use
|
|
37
|
+ interface through famous du utility. It allows one to browse through the
|
|
38
|
+ directories and show percentages of disk usage with ncurses library.
|
|
39
|
+endef
|
|
40
|
+
|
|
41
|
+define Package/ncdu/install
|
|
42
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
43
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ncdu $(1)/usr/bin/
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+$(eval $(call BuildPackage,ncdu))
|