Procházet zdrojové kódy

postgresql: update to 9.4.1

- supports arm64/aarch64

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Dirk Neukirchen před 9 roky
rodič
revize
6ae54e4075

+ 4
- 10
libs/postgresql/Makefile Zobrazit soubor

@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=postgresql
11
-PKG_VERSION:=9.0.17
11
+PKG_VERSION:=9.4.1
12 12
 PKG_RELEASE:=1
13 13
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
14 14
 PKG_LICENSE:=PostgreSQL
@@ -18,10 +18,11 @@ PKG_SOURCE_URL:=\
18 18
 	http://ftp9.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
19 19
 	http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
20 20
 	ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
21
-PKG_MD5SUM:=46bf3ef3761c091fb0d2e25012c1709e
21
+PKG_MD5SUM:=2cf30f50099ff1109d0aa517408f8eff
22 22
 PKG_BUILD_PARALLEL:=1
23 23
 PKG_USE_MIPS16:=0
24 24
 PKG_FIXUP:=autoreconf
25
+PKG_MACRO_PATHS:=config
25 26
 
26 27
 include $(INCLUDE_DIR)/package.mk
27 28
 
@@ -85,17 +86,13 @@ define Build/Configure
85 86
 			--enable-static \
86 87
 			--disable-integer-datetimes \
87 88
 			--disable-rpath \
88
-			--without-java \
89
-			--without-krb4 \
90 89
 			--without-krb5 \
91 90
 			--without-openssl \
92 91
 			--without-pam \
93 92
 			--without-perl \
94 93
 			--without-python \
95 94
 			--without-readline \
96
-			--without-rendezvous \
97 95
 			--without-tcl \
98
-			--without-tk \
99 96
 			--with-zlib="yes" \
100 97
 			--enable-depend \
101 98
 			--with-system-timezone=/tmp \
@@ -141,16 +138,12 @@ define Build/Configure
141 138
 			--enable-static \
142 139
 			--disable-integer-datetimes \
143 140
 			--disable-rpath \
144
-			--without-java \
145
-			--without-krb4 \
146 141
 			--without-krb5 \
147 142
 			--without-openssl \
148 143
 			--without-pam \
149 144
 			--without-perl \
150 145
 			--without-python \
151
-			--without-rendezvous \
152 146
 			--without-tcl \
153
-			--without-tk \
154 147
 			--with-zlib="yes" \
155 148
 			--enable-depend \
156 149
 			$(if $(CONFIG_TARGET_avr32),--disable-spinlocks) \
@@ -242,6 +235,7 @@ define Build/InstallDev
242 235
 	$(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config.h $(1)/usr/include/
243 236
 	$(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config_manual.h $(1)/usr/include/
244 237
 	$(CP) $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(1)/usr/include/
238
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config_ext.h $(1)/usr/include/
245 239
 	$(CP) $(PKG_INSTALL_DIR)/usr/include/postgresql $(1)/usr/include/
246 240
 	$(INSTALL_DIR) $(1)/usr/lib
247 241
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpq.{a,so*} $(1)/usr/lib/

+ 11
- 0
libs/postgresql/patches/001-configure_fixes.patch Zobrazit soubor

@@ -0,0 +1,11 @@
1
+--- a/configure.in
2
++++ b/configure.in
3
+@@ -25,7 +25,7 @@ recommended.  You can remove the check f
4
+ your responsibility whether the result works or not.])])
5
+ AC_COPYRIGHT([Copyright (c) 1996-2014, PostgreSQL Global Development Group])
6
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
7
+-AC_CONFIG_AUX_DIR(config)
8
++AC_CONFIG_AUX_DIR([config])
9
+ AC_PREFIX_DEFAULT(/usr/local/pgsql)
10
+ AC_SUBST(configure_args, [$ac_configure_args])
11
+ 

+ 2
- 2
libs/postgresql/patches/200-ranlib.patch Zobrazit soubor

@@ -1,10 +1,10 @@
1 1
 --- a/src/port/Makefile
2 2
 +++ b/src/port/Makefile
3
-@@ -53,6 +53,7 @@ uninstall:
3
+@@ -52,6 +52,7 @@ uninstall:
4 4
  
5 5
  libpgport.a: $(OBJS)
6 6
  	$(AR) $(AROPT) $@ $^
7 7
 +	$(RANLIB) libpgport.a
8 8
  
9 9
  # thread.o needs PTHREAD_CFLAGS (but thread_srv.o does not)
10
- thread.o: thread.c
10
+ thread.o: CFLAGS+=$(PTHREAD_CFLAGS)

+ 1
- 1
libs/postgresql/patches/800-busybox-default-pager.patch Zobrazit soubor

@@ -1,6 +1,6 @@
1 1
 --- a/src/bin/psql/print.h
2 2
 +++ b/src/bin/psql/print.h
3
-@@ -171,10 +171,6 @@ extern void printQuery(const PGresult *r
3
+@@ -179,10 +179,6 @@ extern void printQuery(const PGresult *r
4 4
  extern void setDecimalLocale(void);
5 5
  extern const printTextFormat *get_line_style(const printTableOpt *opt);
6 6