|
@@ -8,7 +8,7 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=postgresql
|
11
|
|
-PKG_VERSION:=9.0.17
|
|
11
|
+PKG_VERSION:=9.4.1
|
12
|
12
|
PKG_RELEASE:=1
|
13
|
13
|
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
|
14
|
14
|
PKG_LICENSE:=PostgreSQL
|
|
@@ -18,10 +18,11 @@ PKG_SOURCE_URL:=\
|
18
|
18
|
http://ftp9.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
|
19
|
19
|
http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
|
20
|
20
|
ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
|
21
|
|
-PKG_MD5SUM:=46bf3ef3761c091fb0d2e25012c1709e
|
|
21
|
+PKG_MD5SUM:=2cf30f50099ff1109d0aa517408f8eff
|
22
|
22
|
PKG_BUILD_PARALLEL:=1
|
23
|
23
|
PKG_USE_MIPS16:=0
|
24
|
24
|
PKG_FIXUP:=autoreconf
|
|
25
|
+PKG_MACRO_PATHS:=config
|
25
|
26
|
|
26
|
27
|
include $(INCLUDE_DIR)/package.mk
|
27
|
28
|
|
|
@@ -85,17 +86,13 @@ define Build/Configure
|
85
|
86
|
--enable-static \
|
86
|
87
|
--disable-integer-datetimes \
|
87
|
88
|
--disable-rpath \
|
88
|
|
- --without-java \
|
89
|
|
- --without-krb4 \
|
90
|
89
|
--without-krb5 \
|
91
|
90
|
--without-openssl \
|
92
|
91
|
--without-pam \
|
93
|
92
|
--without-perl \
|
94
|
93
|
--without-python \
|
95
|
94
|
--without-readline \
|
96
|
|
- --without-rendezvous \
|
97
|
95
|
--without-tcl \
|
98
|
|
- --without-tk \
|
99
|
96
|
--with-zlib="yes" \
|
100
|
97
|
--enable-depend \
|
101
|
98
|
--with-system-timezone=/tmp \
|
|
@@ -141,16 +138,12 @@ define Build/Configure
|
141
|
138
|
--enable-static \
|
142
|
139
|
--disable-integer-datetimes \
|
143
|
140
|
--disable-rpath \
|
144
|
|
- --without-java \
|
145
|
|
- --without-krb4 \
|
146
|
141
|
--without-krb5 \
|
147
|
142
|
--without-openssl \
|
148
|
143
|
--without-pam \
|
149
|
144
|
--without-perl \
|
150
|
145
|
--without-python \
|
151
|
|
- --without-rendezvous \
|
152
|
146
|
--without-tcl \
|
153
|
|
- --without-tk \
|
154
|
147
|
--with-zlib="yes" \
|
155
|
148
|
--enable-depend \
|
156
|
149
|
$(if $(CONFIG_TARGET_avr32),--disable-spinlocks) \
|
|
@@ -242,6 +235,7 @@ define Build/InstallDev
|
242
|
235
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config.h $(1)/usr/include/
|
243
|
236
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config_manual.h $(1)/usr/include/
|
244
|
237
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(1)/usr/include/
|
|
238
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config_ext.h $(1)/usr/include/
|
245
|
239
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/postgresql $(1)/usr/include/
|
246
|
240
|
$(INSTALL_DIR) $(1)/usr/lib
|
247
|
241
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpq.{a,so*} $(1)/usr/lib/
|