Browse Source

Merge pull request #123 from Naoir/perl

perl: More bugfixes, correct PKG_LICENSE
sbyx 10 years ago
parent
commit
6eb2ac4815

+ 12
- 4
lang/perl/Makefile View File

@@ -9,8 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl
11 11
 PKG_VERSION:=5.20.0
12
-PKG_RELEASE:=3
13
-PKG_MD5SUM:=406ec049ebe3afcc80d9c76ec78ca4f8
12
+PKG_RELEASE:=4
14 13
 
15 14
 PKG_SOURCE_URL:=ftp://ftp.cpan.org/pub/CPAN/src/5.0 \
16 15
 		http://www.cpan.org/src/5.0/perl-5.20.0.tar.gz \
@@ -21,8 +20,9 @@ PKG_SOURCE_URL:=ftp://ftp.cpan.org/pub/CPAN/src/5.0 \
21 20
 		ftp://ftp.funet.fi/pub/languages/perl/CPAN/src/5.0 \
22 21
 		http://ftp.funet.fi/pub/languages/perl/CPAN/src/5.0
23 22
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
23
+PKG_MD5SUM:=406ec049ebe3afcc80d9c76ec78ca4f8
24 24
 
25
-PKG_LICENSE:=GPLv1 ARTISTIC
25
+PKG_LICENSE:=GPLv1+ ARTISTIC
26 26
 PKG_LICENSE_FILES:=Copying Artistic README
27 27
 PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
28 28
 
@@ -39,6 +39,9 @@ ifneq ($(CONFIG_USE_EGLIBC),)
39 39
 	EXTRA_LIBS:=bsd
40 40
 	EXTRA_LIBDIRS:=$(STAGING_DIR)/lib
41 41
 endif
42
+# Filter -g3, it will break Compress-Raw-Zlib
43
+TARGET_CFLAGS_PERL:=$(patsubst -g3,-g,$(TARGET_CFLAGS))
44
+TARGET_CPPFLAGS_PERL:=$(patsubst -g3,-g,$(TARGET_CPPFLAGS))
42 45
 
43 46
 include $(INCLUDE_DIR)/package.mk
44 47
 include $(INCLUDE_DIR)/host-build.mk
@@ -72,7 +75,7 @@ endef
72 75
 define Build/Configure
73 76
 	sed \
74 77
 		-e 's!%%CC%%!$(TARGET_CC)!g' \
75
-		-e 's!%%CFLAGS%%!$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)!g' \
78
+		-e 's!%%CFLAGS%%!$(TARGET_CFLAGS_PERL) $(TARGET_CPPFLAGS_PERL)!g' \
76 79
 		-e 's!%%CPP%%!$(TARGET_CROSS)gcc -E!g' \
77 80
 		-e 's!%%AR%%!$(TARGET_CROSS)ar!g' \
78 81
 		-e 's!%%LD%%!$(TARGET_CROSS)gcc!g' \
@@ -94,6 +97,11 @@ define Build/Compile
94 97
 	+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)
95 98
 endef
96 99
 
100
+define Build/InstallDev
101
+	$(INSTALL_DIR) $(1)/usr/lib/perl5/5.20/CORE
102
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/perl5/5.20/CORE/*.h $(1)/usr/lib/perl5/5.20/CORE/
103
+endef
104
+
97 105
 define Package/perl/install
98 106
 	$(INSTALL_DIR) $(1)/usr/bin
99 107
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/perl$(PKG_VERSION) $(1)/usr/bin

+ 4
- 4
lang/perl/files/config.sh-arm.in View File

@@ -601,13 +601,13 @@ html1direxp=''
601 601
 html3dir=' '
602 602
 html3direxp=''
603 603
 i16size='2'
604
-i16type='short'
604
+i16type='signed short'
605 605
 i32size='4'
606
-i32type='long'
606
+i32type='signed long'
607 607
 i64size='8'
608
-i64type='long long'
608
+i64type='signed long long'
609 609
 i8size='1'
610
-i8type='char'
610
+i8type='signed char'
611 611
 i_arpainet='define'
612 612
 i_bsdioctl=''
613 613
 i_crypt='define'

+ 4
- 4
lang/perl/files/config.sh-armeb.in View File

@@ -601,13 +601,13 @@ html1direxp=''
601 601
 html3dir=' '
602 602
 html3direxp=''
603 603
 i16size='2'
604
-i16type='short'
604
+i16type='signed short'
605 605
 i32size='4'
606
-i32type='long'
606
+i32type='signed long'
607 607
 i64size='8'
608
-i64type='long long'
608
+i64type='signed long long'
609 609
 i8size='1'
610
-i8type='char'
610
+i8type='signed char'
611 611
 i_arpainet='define'
612 612
 i_bsdioctl=''
613 613
 i_crypt='define'

+ 3
- 3
lang/perl/files/config.sh-x86_64.in View File

@@ -547,7 +547,7 @@ fflushall='undef'
547 547
 find=''
548 548
 firstmakefile='makefile'
549 549
 flex=''
550
-fpossize='20'
550
+fpossize='16'
551 551
 fpostype='fpos_t'
552 552
 freetype='void'
553 553
 from=':'
@@ -604,7 +604,7 @@ i32type='int'
604 604
 i64size='8'
605 605
 i64type='long'
606 606
 i8size='1'
607
-i8type='char'
607
+i8type='signed char'
608 608
 i_arpainet='define'
609 609
 i_bsdioctl=''
610 610
 i_crypt='define'
@@ -943,7 +943,7 @@ subversion='0'
943 943
 sysman='/usr/share/man/man1'
944 944
 tail=''
945 945
 tar=''
946
-targetarch='i386-linux-uclibc'
946
+targetarch='x86_64-linux-uclibc'
947 947
 tbl=''
948 948
 tee=''
949 949
 test='test'

+ 1
- 1
lang/perl/perlbase.mk View File

@@ -458,7 +458,7 @@ TITLE:=essential perl module
458 458
 endef
459 459
 
460 460
 define Package/perlbase-essential/install
461
-$(call perlmod/Install,$(1),Carp Carp.pm Exporter Exporter.pm constant.pm lib.pm locale.pm overload.pm strict.pm subs.pm vars.pm warnings warnings.pm,)
461
+$(call perlmod/Install,$(1),Carp Carp.pm Exporter Exporter.pm constant.pm lib.pm locale.pm overload.pm strict.pm subs.pm vars.pm warnings warnings.pm overloading.pm,)
462 462
 endef
463 463
 
464 464
 $(eval $(call BuildPackage,perlbase-essential))

+ 4
- 2
lang/perl/perlmod.mk View File

@@ -20,6 +20,7 @@ define perlmod/Configure
20 20
 		$(1) \
21 21
 		AR=ar \
22 22
 		CC=$(GNU_TARGET_NAME)-gcc \
23
+		CCFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
23 24
 		CCCDLFLAGS=-fPIC \
24 25
 		CCDLFLAGS=-Wl,-E \
25 26
 		DLEXT=so \
@@ -62,6 +63,7 @@ define perlmod/Configure
62 63
 		LINKTYPE=dynamic \
63 64
 		DESTDIR=$(PKG_INSTALL_DIR) \
64 65
 	);
66
+	sed 's!^PERL_INC = .*!PERL_INC = $(STAGING_DIR)/usr/lib/perl5/5.20/CORE/!' -i $(PKG_BUILD_DIR)/Makefile
65 67
 endef
66 68
 
67 69
 define perlmod/Compile
@@ -87,8 +89,8 @@ define perlmod/Install
87 89
 	@echo "---> Stripping modules in: $(strip $(1))$(PERL_SITELIB)"
88 90
 	find $(strip $(1))$(PERL_SITELIB) -name \*.pm -or -name \*.pl | \
89 91
 	xargs -r sed -i \
90
-		-e '/^=\(head\|pod\|item\|over\|back\)/,/^=cut/d' \
91
-		-e '/^=\(head\|pod\|item\|over\|back\)/,$$$$d' \
92
+		-e '/^=\(head\|pod\|item\|over\|back\|encoding\)/,/^=cut/d' \
93
+		-e '/^=\(head\|pod\|item\|over\|back\|encoding\)/,$$$$d' \
92 94
 		-e '/^#$$$$/d' \
93 95
 		-e '/^#[^!"'"'"']/d'
94 96
 endef