|
@@ -0,0 +1,55 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=opentracker
|
|
11
|
+PKG_VERSION:=20130804
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+PKG_REV:=954f5029dfa17734dc408336ef710c192268e8a4
|
|
14
|
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
|
15
|
+
|
|
16
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
17
|
+PKG_SOURCE_URL:=git://erdgeist.org/opentracker
|
|
18
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
19
|
+PKG_SOURCE_VERSION:=$(PKG_REV)
|
|
20
|
+PKG_SOURCE_PROTO:=git
|
|
21
|
+PKG_BUILD_DEPENDS:=libowfat
|
|
22
|
+
|
|
23
|
+include $(INCLUDE_DIR)/package.mk
|
|
24
|
+
|
|
25
|
+define Package/opentracker
|
|
26
|
+ SUBMENU:=BitTorrent
|
|
27
|
+ SECTION:=net
|
|
28
|
+ CATEGORY:=Network
|
|
29
|
+ TITLE:=opentracker
|
|
30
|
+ URL:=http://erdgeist.org/arts/software/opentracker/
|
|
31
|
+ DEPENDS:=+zlib +libpthread
|
|
32
|
+endef
|
|
33
|
+
|
|
34
|
+define Package/opentracker/description
|
|
35
|
+ opentracker - An open and free bittorrent tracker
|
|
36
|
+
|
|
37
|
+ opentracker is an open and free bittorrent tracker project.
|
|
38
|
+ It aims for minimal resource usage and is intended to run at your wlan router.
|
|
39
|
+ Currently it is deployed as an open and free tracker instance.
|
|
40
|
+ Read our free and open tracker blog and announce your torrents there
|
|
41
|
+ (but do not hesitate to setup your own free trackers!).
|
|
42
|
+endef
|
|
43
|
+
|
|
44
|
+MAKE_FLAGS += PREFIX="$(STAGING_DIR)/usr"
|
|
45
|
+
|
|
46
|
+define Package/opentracker/install
|
|
47
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
48
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/opentracker $(1)/usr/bin
|
|
49
|
+ $(INSTALL_DIR) $(1)/etc
|
|
50
|
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/opentracker.conf.sample $(1)/etc/opentracker.conf
|
|
51
|
+ $(INSTALL_DIR) $(1)/etc/init.d
|
|
52
|
+ $(INSTALL_BIN) ./files/opentracker.init $(1)/etc/init.d/opentracker
|
|
53
|
+endef
|
|
54
|
+
|
|
55
|
+$(eval $(call BuildPackage,opentracker))
|