|
@@ -0,0 +1,60 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2007-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=nail
|
|
11
|
+PKG_VERSION:=
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+PKG_LICENSE:=BSD-2-Clause
|
|
14
|
+
|
|
15
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
16
|
+PKG_SOURCE_URL:=:pserver:anonymous@nail.cvs.sourceforge.net:/cvsroot/nail
|
|
17
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)
|
|
18
|
+PKG_SOURCE_VERSION:=-DNOW
|
|
19
|
+PKG_SOURCE_PROTO:=cvs
|
|
20
|
+
|
|
21
|
+PKG_INSTALL:=0
|
|
22
|
+
|
|
23
|
+include $(INCLUDE_DIR)/package.mk
|
|
24
|
+
|
|
25
|
+define Package/nail
|
|
26
|
+ SECTION:=mail
|
|
27
|
+ CATEGORY:=Mail
|
|
28
|
+ TITLE:=Heirloom mailx (nail)
|
|
29
|
+ URL:=http://heirloom.sourceforge.net/mailx.html
|
|
30
|
+ MAINTAINER:=Dmitry V. Zimin <pfzim@mail.ru>
|
|
31
|
+ DEPENDS:=+libopenssl
|
|
32
|
+endef
|
|
33
|
+
|
|
34
|
+define Package/nail/description
|
|
35
|
+ Heirloom mailx (formerly known as "nail") is intended provide
|
|
36
|
+ the functionality of the POSIX mailx command with additional
|
|
37
|
+ support for MIME messages, IMAP (including caching), POP3,
|
|
38
|
+ SMTP, S/MIME, message threading/sorting, scoring, and filtering
|
|
39
|
+endef
|
|
40
|
+
|
|
41
|
+define Package/nail/conffiles
|
|
42
|
+/etc/nail.rc
|
|
43
|
+endef
|
|
44
|
+
|
|
45
|
+define Build/Install
|
|
46
|
+ $(INSTALL_DIR) $(PKG_INSTALL_DIR)/usr/bin
|
|
47
|
+ $(CP) $(PKG_BUILD_DIR)/mailx $(PKG_INSTALL_DIR)/usr/bin/
|
|
48
|
+ $(INSTALL_DIR) $(PKG_INSTALL_DIR)/etc
|
|
49
|
+ $(CP) $(PKG_BUILD_DIR)/nail.rc $(PKG_INSTALL_DIR)/etc/
|
|
50
|
+endef
|
|
51
|
+
|
|
52
|
+define Package/nail/install
|
|
53
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
54
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
|
|
55
|
+ $(INSTALL_DIR) $(1)/etc
|
|
56
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/* $(1)/etc/
|
|
57
|
+endef
|
|
58
|
+
|
|
59
|
+$(eval $(call BuildPackage,nail))
|
|
60
|
+
|