Browse Source

ibrcommon: add new package

The ibrcommon is a C++ abstraction library for several platforms (linux,
win32, osx, ...) and is development together with IBR-DTN an implementation
of DTN stack following the Bundle Protocol RFC 5050.

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Johannes Morgenroth 10 years ago
parent
commit
74e2ccff82
1 changed files with 50 additions and 0 deletions
  1. 50
    0
      libs/ibrcommon/Makefile

+ 50
- 0
libs/ibrcommon/Makefile View File

@@ -0,0 +1,50 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=ibrcommon
11
+PKG_VERSION:=0.12.1
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
16
+PKG_MD5SUM:=45681f48138bbbbd17384d25dc91454a
17
+PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
18
+PKG_LICENSE:=Apache-2.0
19
+
20
+PKG_INSTALL:=1
21
+PKG_FIXUP:=libtool
22
+PKG_BUILD_DEPENDS:=libnl libopenssl
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/ibrcommon
27
+  SECTION:=libs
28
+  CATEGORY:=Libraries
29
+  DEPENDS:=+libstdcpp +libpthread +librt +libnl +libopenssl
30
+  TITLE:=IBR Common C++ Library
31
+endef
32
+
33
+CONFIGURE_ARGS += \
34
+	--with-openssl
35
+
36
+define Package/ibrcommon/description
37
+ A library with common functions for C++.
38
+endef
39
+
40
+define Build/InstallDev
41
+	$(INSTALL_DIR) $(1)
42
+	$(CP) $(PKG_INSTALL_DIR)/* $(1)/
43
+endef
44
+
45
+define Package/ibrcommon/install
46
+	$(INSTALL_DIR) $(1)/usr/lib
47
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib$(PKG_NAME){.so,-$(PKG_VERSION_MAJOR).$(PKG_VERSION_MINOR).so.*} $(1)/usr/lib/
48
+endef
49
+
50
+$(eval $(call BuildPackage,ibrcommon))