Browse Source

dtndht: add new package

DTN-DHT is a library providing a fully distributed Bittorrent DHT based
naming service especially for DTN Bundle Protocol EIDs (RFC 5050). It can
be used for all IP (v4/v6) based networks.

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Johannes Morgenroth 10 years ago
parent
commit
c8b84ec8ae
1 changed files with 47 additions and 0 deletions
  1. 47
    0
      libs/dtndht/Makefile

+ 47
- 0
libs/dtndht/Makefile View File

@@ -0,0 +1,47 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=dtndht
11
+PKG_VERSION:=0.2.3
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
16
+PKG_MD5SUM:=37c33910ac7e760aad4db81724aeb4fb
17
+PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
18
+PKG_LICENSE:=Apache-2.0
19
+
20
+PKG_INSTALL:=1
21
+PKG_FIXUP:=libtool
22
+PKG_BUILD_DEPENDS:=libopenssl
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/dtndht
27
+  SECTION:=libs
28
+  CATEGORY:=Libraries
29
+  DEPENDS:=+libopenssl
30
+  TITLE:=Library for DHT lookups for DTNs
31
+endef
32
+
33
+define Package/dtndht/description
34
+ A library with DHT functions for DTN name lookups.
35
+endef
36
+
37
+define Build/InstallDev
38
+	$(INSTALL_DIR) $(1)
39
+	$(CP) $(PKG_INSTALL_DIR)/* $(1)/
40
+endef
41
+
42
+define Package/dtndht/install
43
+	$(INSTALL_DIR) $(1)/usr/lib
44
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib$(PKG_NAME){.so,-$(PKG_VERSION_MAJOR).$(PKG_VERSION_MINOR).so.*} $(1)/usr/lib/
45
+endef
46
+
47
+$(eval $(call BuildPackage,dtndht))