|
@@ -45,7 +45,7 @@ $(call Package/perl/Default)
|
45
|
45
|
endef
|
46
|
46
|
|
47
|
47
|
define Package/microperl/description
|
48
|
|
- A perl package without operating-specific functions such as readdir.
|
|
48
|
+ A perl package without operating-specific functions such as readdir.
|
49
|
49
|
endef
|
50
|
50
|
|
51
|
51
|
define Build/Template
|
|
@@ -87,9 +87,9 @@ $(call Package/perl/Default)
|
87
|
87
|
endef
|
88
|
88
|
|
89
|
89
|
define Package/perl/description
|
90
|
|
- Perl is a stable, cross platform programming language.
|
91
|
|
- It is used for mission critical projects in the public and private sectors
|
92
|
|
- and is widely used to program web applications of all needs.
|
|
90
|
+ Perl is a stable, cross platform programming language.
|
|
91
|
+ It is used for mission critical projects in the public and private sectors
|
|
92
|
+ and is widely used to program web applications of all needs.
|
93
|
93
|
endef
|
94
|
94
|
|
95
|
95
|
define Build/perl/Configure
|
|
@@ -140,10 +140,9 @@ define Build/perl/Compile
|
140
|
140
|
# been generated if we weren't cross compiling
|
141
|
141
|
echo -e 'miniperl.target:\n\t$$$$(CC) $$$$(CLDFLAGS) -o miniperl.target $$$$(mini_obj) $$$$(libs)' >> $(PKG_BUILD_DIR)/Makefile
|
142
|
142
|
+$(MAKE) $(MAKE_J) -C $(PKG_BUILD_DIR) miniperl.target
|
143
|
|
-
|
144
|
143
|
mkdir -p $(PKG_BUILD_DIR)/target-bin
|
145
|
144
|
install -m 0755 $(PKG_BUILD_DIR)/miniperl.target $(PKG_BUILD_DIR)/target-bin/miniperl
|
146
|
|
-
|
|
145
|
+
|
147
|
146
|
@echo
|
148
|
147
|
@echo "===> Stage 5: Build target perl binary"
|
149
|
148
|
@echo
|