|
@@ -15,10 +15,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
|
15
|
15
|
Makefile.in | 10 ++--------
|
16
|
16
|
1 file changed, 2 insertions(+), 8 deletions(-)
|
17
|
17
|
|
18
|
|
-Index: apr-1.5.1/Makefile.in
|
|
18
|
+Index: apr-1.5.2/Makefile.in
|
19
|
19
|
===================================================================
|
20
|
|
---- apr-1.5.1.orig/Makefile.in
|
21
|
|
-+++ apr-1.5.1/Makefile.in
|
|
20
|
+--- apr-1.5.2.orig/Makefile.in
|
|
21
|
++++ apr-1.5.2/Makefile.in
|
22
|
22
|
@@ -20,7 +20,7 @@ INCDIR=./include
|
23
|
23
|
OSDIR=$(top_srcdir)/include/arch/@OSDIR@
|
24
|
24
|
DEFOSDIR=$(INCDIR)/arch/@DEFAULT_OSDIR@
|
|
@@ -36,19 +36,16 @@ Index: apr-1.5.1/Makefile.in
|
36
|
36
|
include/private/apr_escape_test_char.h
|
37
|
37
|
DISTCLEAN_TARGETS = config.cache config.log config.status \
|
38
|
38
|
include/apr.h include/arch/unix/apr_private.h \
|
39
|
|
-@@ -130,13 +129,8 @@ check: $(TARGET_LIB)
|
40
|
|
- etags:
|
41
|
|
- etags `find . -name '*.[ch]'`
|
|
39
|
+@@ -135,9 +134,9 @@ tools/gen_test_char.lo: tools/gen_test_c
|
|
40
|
+ $(APR_MKDIR) tools
|
|
41
|
+ $(LT_COMPILE)
|
42
|
42
|
|
43
|
|
--make_tools_dir:
|
44
|
|
-- $(APR_MKDIR) tools
|
45
|
|
--
|
46
|
|
--OBJECTS_gen_test_char = tools/gen_test_char.lo $(LOCAL_LIBS)
|
47
|
|
--tools/gen_test_char.lo: make_tools_dir
|
48
|
43
|
-tools/gen_test_char@EXEEXT@: $(OBJECTS_gen_test_char)
|
49
|
44
|
- $(LINK_PROG) $(OBJECTS_gen_test_char) $(ALL_LIBS)
|
|
45
|
+-
|
50
|
46
|
+tools/gen_test_char@EXEEXT@: tools/gen_test_char.c
|
51
|
47
|
+ $(BUILDCC) $(CFLAGS_FOR_BUILD) $< -o $@
|
52
|
|
-
|
|
48
|
++
|
53
|
49
|
include/private/apr_escape_test_char.h: tools/gen_test_char@EXEEXT@
|
54
|
50
|
$(APR_MKDIR) include/private
|
|
51
|
+ tools/gen_test_char@EXEEXT@ > $@
|