Pārlūkot izejas kodu

apr: upgrade to 1.5.4

Signed-off-by: heil <heil@terminal-consulting.de>
heil 9 gadus atpakaļ
vecāks
revīzija
7c331284e0

+ 2
- 2
libs/apr/Makefile Parādīt failu

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=apr
11
-PKG_VERSION:=1.5.1
11
+PKG_VERSION:=1.5.2
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=http://mirrors.ibiblio.org/apache/apr/
16
-PKG_MD5SUM:=5486180ec5a23efb5cae6d4292b300ab
16
+PKG_MD5SUM:=4e9769f3349fe11fc0a5e1b224c236aa
17 17
 PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
18 18
 PKG_LICENSE:=Apache License
19 19
 

+ 9
- 5
libs/apr/patches/001-autoconf-compat.patch Parādīt failu

@@ -1,5 +1,7 @@
1
---- a/Makefile.in
2
-+++ b/Makefile.in
1
+Index: apr-1.5.2/Makefile.in
2
+===================================================================
3
+--- apr-1.5.2.orig/Makefile.in
4
++++ apr-1.5.2/Makefile.in
3 5
 @@ -3,6 +3,7 @@ srcdir=@srcdir@
4 6
  VPATH=@srcdir@
5 7
  top_srcdir=@apr_srcdir@
@@ -8,9 +10,11 @@
8 10
  
9 11
  #
10 12
  # APR (Apache Portable Runtime) library Makefile.
11
---- a/configure.in
12
-+++ b/configure.in
13
-@@ -246,9 +246,6 @@ case $host in
13
+Index: apr-1.5.2/configure.in
14
+===================================================================
15
+--- apr-1.5.2.orig/configure.in
16
++++ apr-1.5.2/configure.in
17
+@@ -245,9 +245,6 @@ case $host in
14 18
      gcc $CFLAGS $CPPFLAGS -o $LIBTOOL.exe $LIBTOOL.c
15 19
      ;;
16 20
  *)

+ 9
- 12
libs/apr/patches/201-upgrade-and-fix-1.5.1.patch Parādīt failu

@@ -15,10 +15,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
15 15
  Makefile.in | 10 ++--------
16 16
  1 file changed, 2 insertions(+), 8 deletions(-)
17 17
 
18
-Index: apr-1.5.1/Makefile.in
18
+Index: apr-1.5.2/Makefile.in
19 19
 ===================================================================
20
---- apr-1.5.1.orig/Makefile.in
21
-+++ apr-1.5.1/Makefile.in
20
+--- apr-1.5.2.orig/Makefile.in
21
++++ apr-1.5.2/Makefile.in
22 22
 @@ -20,7 +20,7 @@ INCDIR=./include
23 23
  OSDIR=$(top_srcdir)/include/arch/@OSDIR@
24 24
  DEFOSDIR=$(INCDIR)/arch/@DEFAULT_OSDIR@
@@ -36,19 +36,16 @@ Index: apr-1.5.1/Makefile.in
36 36
  	include/private/apr_escape_test_char.h
37 37
  DISTCLEAN_TARGETS = config.cache config.log config.status \
38 38
  	include/apr.h include/arch/unix/apr_private.h \
39
-@@ -130,13 +129,8 @@ check: $(TARGET_LIB)
40
- etags:
41
- 	etags `find . -name '*.[ch]'`
39
+@@ -135,9 +134,9 @@ tools/gen_test_char.lo: tools/gen_test_c
40
+ 	$(APR_MKDIR) tools
41
+ 	$(LT_COMPILE)
42 42
  
43
--make_tools_dir:
44
--	$(APR_MKDIR) tools
45
--
46
--OBJECTS_gen_test_char = tools/gen_test_char.lo $(LOCAL_LIBS)
47
--tools/gen_test_char.lo: make_tools_dir
48 43
 -tools/gen_test_char@EXEEXT@: $(OBJECTS_gen_test_char)
49 44
 -	$(LINK_PROG) $(OBJECTS_gen_test_char) $(ALL_LIBS)
45
+-
50 46
 +tools/gen_test_char@EXEEXT@: tools/gen_test_char.c
51 47
 +	$(BUILDCC) $(CFLAGS_FOR_BUILD) $< -o $@
52
- 
48
++ 
53 49
  include/private/apr_escape_test_char.h: tools/gen_test_char@EXEEXT@
54 50
  	$(APR_MKDIR) include/private
51
+ 	tools/gen_test_char@EXEEXT@ > $@