Browse Source

libvorbisidec: Update to lastest tremor version (1.0.3) from xiph.org

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
7f58b0254f
1 changed files with 13 additions and 6 deletions
  1. 13
    6
      libs/libvorbisidec/Makefile

+ 13
- 6
libs/libvorbisidec/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2014 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,12 +8,18 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libvorbisidec
11
-PKG_VERSION:=1.0.2+svn18153
12
-PKG_RELEASE:=2
11
+PKG_REV:=20150104
12
+PKG_VERSION:=1.0.3-$(PKG_REV)
13
+PKG_RELEASE:=1
14
+
15
+PKG_SOURCE_PROTO:=git
16
+PKG_SOURCE_URL:=git://git.xiph.org/tremor.git
17
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
18
+PKG_SOURCE_VERSION:=b56ffce0c0773ec5ca04c466bc00b1bbcaf65aef
19
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
13 22
 
14
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
15
-PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/libv/libvorbisidec/
16
-PKG_MD5SUM:=4190859414c5d6760e316b5cf00fe7c5
17 23
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
18 24
 
19 25
 PKG_LICENSE:=BSD-3-Clause
@@ -21,6 +27,7 @@ PKG_LICENSE_FILES:=COPYING
21 27
 
22 28
 PKG_FIXUP:=autoreconf
23 29
 PKG_INSTALL:=1
30
+PKG_USE_MIPS16:=0
24 31
 
25 32
 include $(INCLUDE_DIR)/package.mk
26 33