Explorar el Código

Merge pull request #619 from commodo/python-cleanup

Python cleanup
Steven Barth hace 10 años
padre
commit
81545ba281

+ 0
- 2
lang/python-pip/Makefile Ver fichero

@@ -34,9 +34,7 @@ define Package/python-pip/description
34 34
   A tool for installing and managing Python packages.
35 35
 endef
36 36
 
37
-PYTHONPATH:=$(PKG_INSTALL_DIR)/$(PYTHON_PKG_DIR)
38 37
 define Build/Compile
39
-	$(INSTALL_DIR) $(PYTHONPATH)
40 38
 	$(call Build/Compile/PyMod,,\
41 39
 		install --prefix="$(PKG_INSTALL_DIR)/usr" \
42 40
 	)

+ 0
- 2
lang/python-setuptools/Makefile Ver fichero

@@ -33,9 +33,7 @@ define Package/python-setuptools/description
33 33
   Easily download, build, install, upgrade, and uninstall Python packages
34 34
 endef
35 35
 
36
-PYTHONPATH:=$(PKG_INSTALL_DIR)/$(PYTHON_PKG_DIR)
37 36
 define Build/Compile
38
-	$(INSTALL_DIR) $(PYTHONPATH)
39 37
 	$(call Build/Compile/PyMod,,\
40 38
 		install --prefix="$(PKG_INSTALL_DIR)/usr" \
41 39
 	)

+ 2
- 0
lang/python/files/python-package.mk Ver fichero

@@ -21,6 +21,7 @@ HOST_PYTHON_LIB_DIR:=$(STAGING_DIR_HOST)/lib/python$(PYTHON_VERSION)
21 21
 HOST_PYTHON_BIN:=$(STAGING_DIR_HOST)/bin/python2
22 22
 
23 23
 PYTHONPATH:=$(PYTHON_LIB_DIR):$(STAGING_DIR)/$(PYTHON_PKG_DIR)
24
+PYTHONPATH+=:$(PKG_INSTALL_DIR)/$(PYTHON_PKG_DIR)
24 25
 define HostPython
25 26
 	(	export PYTHONPATH="$(PYTHONPATH)"; \
26 27
 		export PYTHONOPTIMIZE=""; \
@@ -79,6 +80,7 @@ endef
79 80
 # $(2) => additional arguments to setup.py
80 81
 # $(3) => additional variables
81 82
 define Build/Compile/PyMod
83
+	$(INSTALL_DIR) $(PKG_INSTALL_DIR)/$(PYTHON_PKG_DIR)
82 84
 	$(call HostPython, \
83 85
 		cd $(PKG_BUILD_DIR)/$(strip $(1)); \
84 86
 		CC="$(TARGET_CC)" \