Browse Source

bogofilter: remove host includes

- host GSL libs are sometimes found leading to errors
reported by buildbot, replicated locally (Arch Linux)

Error:
configure: GSL_LIBS=-L/usr/lib -lgsl -lgslcblas -lm
leading to
/usr/include/features.h:398:23: fatal error: gnu/stubs.h: No such file or directory

- explicit libdb location to prevent host includes

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Dirk Neukirchen 10 years ago
parent
commit
8a307ac786
1 changed files with 4 additions and 1 deletions
  1. 4
    1
      mail/bogofilter/Makefile

+ 4
- 1
mail/bogofilter/Makefile View File

@@ -35,7 +35,10 @@ define Package/bogofilter/description
35 35
 	Bogofilter is a fast Bayesian spam filter
36 36
 endef
37 37
 
38
-CONFIGURE_ARGS += --disable-unicode
38
+CONFIGURE_ARGS += \
39
+	--disable-unicode \
40
+	--with-libdb-prefix=$(STAGING_DIR) \
41
+	--with-included-gsl
39 42
 
40 43
 define Package/bogofilter/install
41 44
 	$(INSTALL_DIR)  $(1)/etc/ \