Browse Source

ffmpeg: remove libavdevice from the libffmpeg-mini variant

As libffmpeg-mini is intended for DLNA purposes, it needs only
to identify media, not interact with input or output devices.

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
Ian Leonard 10 years ago
parent
commit
92e8e56069
1 changed files with 8 additions and 3 deletions
  1. 8
    3
      multimedia/ffmpeg/Makefile

+ 8
- 3
multimedia/ffmpeg/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ffmpeg
11 11
 PKG_VERSION:=0.11.5
12
-PKG_RELEASE:=4
12
+PKG_RELEASE:=5
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=http://ffmpeg.org/releases/
@@ -300,7 +300,7 @@ endef
300 300
 
301 301
 define Package/libffmpeg-custom
302 302
 $(call Package/libffmpeg/Default)
303
- TITLE+= (mini)
303
+ TITLE+= (custom)
304 304
  DEPENDS+= @DEVEL +libspeex
305 305
  VARIANT:=custom
306 306
  MENU:=1
@@ -465,6 +465,7 @@ ifeq ($(BUILD_VARIANT),mini)
465 465
 	--disable-ffplay \
466 466
 	--disable-ffprobe \
467 467
 	--disable-ffserver \
468
+	--disable-avdevice \
468 469
 	--disable-avfilter \
469 470
 	--disable-postproc \
470 471
 	--disable-swresample \
@@ -563,7 +564,11 @@ define Package/libffmpeg-full/install
563 564
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swresample,swscale}.so.* $(1)/usr/lib/
564 565
 endef
565 566
 
566
-Package/libffmpeg-mini/install = $(Package/libffmpeg-custom/install)
567
+define Package/libffmpeg-mini/install
568
+	$(INSTALL_DIR) $(1)/usr/lib
569
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avformat,avutil}.so.* $(1)/usr/lib/
570
+endef
571
+
567 572
 Package/libffmpeg-audio-dec/install = $(Package/libffmpeg-custom/install)
568 573
 
569 574
 $(eval $(call BuildPackage,ffmpeg))