|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2006-2013 OpenWrt.org
|
|
2
|
+# Copyright (C) 2006-2014 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -8,7 +8,7 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=mjpg-streamer
|
11
|
|
-PKG_REV:=181
|
|
11
|
+PKG_REV:=182
|
12
|
12
|
PKG_VERSION:=r$(PKG_REV)
|
13
|
13
|
PKG_RELEASE:=1
|
14
|
14
|
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
|
@@ -19,13 +19,17 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
19
|
19
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
20
|
20
|
PKG_SOURCE_PROTO:=svn
|
21
|
21
|
|
|
22
|
+PKG_LICENSE:=GPL-2.0
|
|
23
|
+PKG_LICENSE_FILE:=LICENSE
|
|
24
|
+
|
22
|
25
|
include $(INCLUDE_DIR)/package.mk
|
23
|
26
|
|
24
|
27
|
define Package/mjpg-streamer
|
25
|
28
|
SECTION:=multimedia
|
26
|
29
|
CATEGORY:=Multimedia
|
27
|
30
|
TITLE:=MJPG-streamer
|
28
|
|
- DEPENDS:=+libpthread +libjpeg
|
|
31
|
+ DEPENDS:=+libpthread +libjpeg +PACKAGE_libv4l:libv4l
|
|
32
|
+#$(if $(CONFIG_MJPG_STREAMER_V4L2),+libv4l)
|
29
|
33
|
URL:=http://mjpg-streamer.wiki.sourceforge.net/
|
30
|
34
|
MENU:=1
|
31
|
35
|
endef
|
|
@@ -44,6 +48,30 @@ define Package/mjpg-streamer/conffiles
|
44
|
48
|
/etc/config/mjpg-streamer
|
45
|
49
|
endef
|
46
|
50
|
|
|
51
|
+CAMBOZOLA:=cambozola-latest.tar.gz
|
|
52
|
+
|
|
53
|
+define Download/cambozola
|
|
54
|
+ URL:=http://www.andywilcock.com/code/cambozola
|
|
55
|
+ FILE:=$(CAMBOZOLA)
|
|
56
|
+ MD5SUM:=6c48fd994685d4d72668850eeb613e24
|
|
57
|
+endef
|
|
58
|
+
|
|
59
|
+# Fetch latest cambozola that works with latest Java(s)
|
|
60
|
+# Yes, I know this is ugly
|
|
61
|
+define Build/Prepare
|
|
62
|
+ $(call Build/Prepare/Default)
|
|
63
|
+ ifeq ($(CONFIG_MJPG_STREAMER_WWW),y)
|
|
64
|
+ $(eval $(call Download,cambozola))
|
|
65
|
+ $(TAR) -xvf $(DL_DIR)/$(CAMBOZOLA) --strip=2 --wildcards \
|
|
66
|
+ -C $(PKG_BUILD_DIR)/www */dist/cambozola.jar
|
|
67
|
+ endif
|
|
68
|
+endef
|
|
69
|
+
|
|
70
|
+ifeq ($(CONFIG_MJPG_STREAMER_V4L2),y)
|
|
71
|
+ TARGET_CFLAGS+= -DUSE_LIBV4L2
|
|
72
|
+ TARGET_LDFLAGS+= -lv4l2
|
|
73
|
+endif
|
|
74
|
+
|
47
|
75
|
define Package/mjpg-streamer/install
|
48
|
76
|
$(INSTALL_DIR) $(1)/usr/bin
|
49
|
77
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mjpg_streamer $(1)/usr/bin/
|
|
@@ -60,6 +88,9 @@ endif
|
60
|
88
|
ifeq ($(CONFIG_MJPG_STREAMER_INPUT_UVC),y)
|
61
|
89
|
$(CP) $(PKG_BUILD_DIR)/input_uvc.so $(1)/usr/lib
|
62
|
90
|
endif
|
|
91
|
+ifeq ($(CONFIG_MJPG_STREAMER_INPUT_TESTPICTURE),y)
|
|
92
|
+ $(CP) $(PKG_BUILD_DIR)/input_testpicture.so $(1)/usr/lib
|
|
93
|
+endif
|
63
|
94
|
ifeq ($(CONFIG_MJPG_STREAMER_OUTPUT_FILE),y)
|
64
|
95
|
$(CP) $(PKG_BUILD_DIR)/output_file.so $(1)/usr/lib
|
65
|
96
|
endif
|