소스 검색

openssh: strip openssh-sftp-server dependencies, notably openssl

openssh-sftp-server is actually a tiny binary that has nearly no dependencies:
$ mips-openwrt-linux-objdump -x sftp-server | grep NEEDED
  NEEDED               libgcc_s.so.1
  NEEDED               libc.so.0

Stripping its DEPENDS allows building a system with SFTP support, without
pulling in OpenSSL.
Catalin Patulea 10 년 전
부모
커밋
99c6c3d830
1개의 변경된 파일1개의 추가작업 그리고 0개의 파일을 삭제
  1. 1
    0
      net/openssh/Makefile

+ 1
- 0
net/openssh/Makefile 파일 보기

@@ -121,6 +121,7 @@ endef
121 121
 define Package/openssh-sftp-server
122 122
 	$(call Package/openssh/Default)
123 123
 	TITLE+= SFTP server
124
+	DEPENDS:=
124 125
 endef
125 126
 
126 127
 define Package/openssh-sftp-server/description