Kaynağa Gözat

Merge pull request #1181 from ryzhovau/ipv6_opt

Optional IPv6 support
Jo-Philipp Wich 9 yıl önce
ebeveyn
işleme
9e2788c96b

+ 2
- 2
lang/ruby/Makefile Dosyayı Görüntüle

@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
11 11
 
12 12
 PKG_NAME:=ruby
13 13
 PKG_VERSION:=2.2.2
14
-PKG_RELEASE:=2
14
+PKG_RELEASE:=3
15 15
 
16 16
 PKG_LIBVER:=2.2
17 17
 
@@ -815,7 +815,7 @@ CONFIGURE_ARGS += \
815 815
 	--enable-shared \
816 816
 	--enable-static \
817 817
 	--disable-rpath \
818
-	--enable-ipv6 \
818
+	$(call autoconf_bool,CONFIG_IPV6,ipv6) \
819 819
 	--disable-install-doc \
820 820
 	--disable-install-capi \
821 821
 	--with-ruby-version=minor \

+ 2
- 2
libs/apr/Makefile Dosyayı Görüntüle

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=apr
11 11
 PKG_VERSION:=1.5.2
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=http://mirrors.ibiblio.org/apache/apr/
@@ -38,7 +38,7 @@ TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
38 38
 CONFIGURE_ARGS += \
39 39
 	--with-devrandom=/dev/urandom \
40 40
 	--disable-dso \
41
-	--enable-ipv6
41
+	$(call autoconf_bool,CONFIG_IPV6,ipv6)
42 42
 
43 43
 # XXX: ac_cv_sizeof_struct_iovec=1 is just to trick configure
44 44
 CONFIGURE_VARS += \

+ 3
- 2
libs/libtorrent/Makefile Dosyayı Görüntüle

@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libtorrent
11
-PKG_VERSION:=0.13.4-git-0
11
+PKG_VERSION:=0.13.4-git-1
12 12
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
13 13
 
14 14
 PKG_SOURCE_PROTO:=git
@@ -49,7 +49,8 @@ CONFIGURE_ARGS+= \
49 49
 	--disable-debug \
50 50
 	--enable-openssl \
51 51
 	--disable-instrumentation \
52
-	--with-zlib=$(STAGING_DIR)/usr
52
+	--with-zlib=$(STAGING_DIR)/usr \
53
+	$(call autoconf_bool,CONFIG_IPV6,ipv6)
53 54
 
54 55
 define Build/InstallDev
55 56
 	$(INSTALL_DIR) $(1)/usr/include

+ 2
- 1
net/mtr/Makefile Dosyayı Görüntüle

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mtr
11 11
 PKG_VERSION:=0.86
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr
@@ -46,6 +46,7 @@ endef
46 46
 CONFIGURE_ARGS += \
47 47
 	--without-gtk \
48 48
 	--without-glib \
49
+	$(call autoconf_bool,CONFIG_IPV6,ipv6)
49 50
 
50 51
 define Build/Configure
51 52
 	(cd $(PKG_BUILD_DIR); touch \

+ 3
- 3
net/nfs-kernel-server/Makefile Dosyayı Görüntüle

@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
8 8
 
9 9
 PKG_NAME:=nfs-kernel-server
10 10
 PKG_VERSION:=1.3.2
11
-PKG_RELEASE:=2
11
+PKG_RELEASE:=3
12 12
 PKG_MD5SUM:=1e2f3c1ed468dee02d00c534c002ea10
13 13
 
14 14
 PKG_SOURCE_URL:=@SF/nfs
@@ -77,12 +77,12 @@ CONFIGURE_ARGS += \
77 77
 	--disable-gss \
78 78
 	--disable-nfsv4 \
79 79
 	--disable-nfsv41 \
80
-	--disable-ipv6 \
81 80
 	--enable-static \
82 81
 	--enable-shared \
83 82
 	--disable-caps \
84 83
 	--disable-tirpc \
85
-	--disable-nfsdcld
84
+	--disable-nfsdcld \
85
+	$(call autoconf_bool,CONFIG_IPV6,ipv6)
86 86
 
87 87
 CONFIGURE_VARS += \
88 88
 	libblkid_cv_is_recent=yes \

+ 3
- 2
net/rtorrent/Makefile Dosyayı Görüntüle

@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=rtorrent
11
-PKG_VERSION:=0.9.4-git-0
11
+PKG_VERSION:=0.9.4-git-1
12 12
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
13 13
 
14 14
 PKG_SOURCE_PROTO:=git
@@ -72,7 +72,8 @@ TARGET_LDFLAGS += -lz -lpthread -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
72 72
 CONFIGURE_ARGS+= \
73 73
 	--enable-shared \
74 74
 	--disable-static \
75
-	--disable-debug
75
+	--disable-debug \
76
+	$(call autoconf_bool,CONFIG_IPV6,ipv6)
76 77
 
77 78
 ifeq ($(BUILD_VARIANT),rpc)
78 79
 	CONFIGURE_ARGS += \

+ 8
- 2
utils/lsof/Makefile Dosyayı Görüntüle

@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
10 10
 
11 11
 PKG_NAME:=lsof
12 12
 PKG_VERSION:=4.86
13
-PKG_RELEASE:=2
13
+PKG_RELEASE:=3
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)+dfsg.orig.tar.gz
16 16
 PKG_SOURCE_URL:=http://ftp2.de.debian.org/debian/pool/main/l/lsof
@@ -32,9 +32,15 @@ define Package/lsof
32 32
   URL:=http://people.freebsd.org/~abe/
33 33
 endef
34 34
 
35
+ifeq ($(CONFIG_IPV6),y)
36
+  LINUX_CLIB_IPV6="-DHASIPv6"
37
+else
38
+  LINUX_CLIB_IPV6=
39
+endif
40
+
35 41
 define Build/Configure
36 42
 	cd $(PKG_BUILD_DIR); \
37
-		LINUX_CLIB="-DGLIBCV=2" \
43
+		LINUX_CLIB="-DGLIBCV=2 $(LINUX_CLIB_IPV6)" \
38 44
 		LSOF_CC="$(TARGET_CC)" \
39 45
 		LSOF_INCLUDE="-I$(STAGING_DIR)/usr/include" \
40 46
 		LSOF_VSTR="$(LINUX_VERSION)" \