Ver código fonte

Merge pull request #1695 from plntyk/fix_postgresql_various

Fix various postgresql issues
Jo-Philipp Wich 9 anos atrás
pai
commit
a137be6d8b
1 arquivos alterados com 18 adições e 2 exclusões
  1. 18
    2
      libs/postgresql/Makefile

+ 18
- 2
libs/postgresql/Makefile Ver arquivo

@@ -42,7 +42,7 @@ endef
42 42
 define Package/pgsql-cli
43 43
   SECTION:=utils
44 44
   CATEGORY:=Utilities
45
-  DEPENDS:=+libpq
45
+  DEPENDS:=+libpq @USE_UCLIBC:+librt
46 46
   TITLE:=Command Line Interface (CLI) to PostgreSQL databases
47 47
   URL:=http://www.postgresql.org/
48 48
   SUBMENU:=database
@@ -55,7 +55,7 @@ endef
55 55
 define Package/pgsql-server
56 56
   SECTION:=utils
57 57
   CATEGORY:=Utilities
58
-  DEPENDS:=+libpq
58
+  DEPENDS:=+libpq @USE_UCLIBC:+librt
59 59
   TITLE:=PostgreSQL databases Server
60 60
   URL:=http://www.postgresql.org/
61 61
   SUBMENU:=database
@@ -66,9 +66,25 @@ define Package/pgsql-server/description
66 66
 PostgreSQL databases Server.
67 67
 endef
68 68
 
69
+PGSQL_CONFIG_VARS:= \
70
+	pgac_cv_snprintf_long_long_int_format="%lld" \
71
+	pgac_cv_snprintf_size_t_support=yes
72
+
73
+ifeq ($(CONFIG_USE_UCLIBC),y)
74
+# PostgreSQL does not build against uClibc with locales
75
+# enabled, due to an uClibc bug, see
76
+# http://lists.uclibc.org/pipermail/uclibc/2014-April/048326.html
77
+# so overwrite automatic detection and disable locale support
78
+PGSQL_CONFIG_VARS+= \
79
+		pgac_cv_type_locale_t=no
80
+endif
81
+
82
+TARGET_CONFIGURE_OPTS+=$(PGSQL_CONFIG_VARS)
83
+
69 84
 # Need a native ecpg ,pg_config, and zic for build
70 85
 define Build/Configure
71 86
 	(cd $(PKG_BUILD_DIR); rm -f config.cache; \
87
+		$(PGSQL_CONFIG_VARS) \
72 88
 		./configure \
73 89
 			--prefix=/usr \
74 90
 			--exec-prefix=/usr \