|
@@ -0,0 +1,49 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=gmpy2
|
|
11
|
+PKG_VERSION:=2.0.7
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
|
|
15
|
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/g/gmpy2
|
|
16
|
+PKG_MD5SUM:=b5aada3ee5afb316ea94604f45192054
|
|
17
|
+
|
|
18
|
+PKG_LICENSE:=LGPL-3.0+
|
|
19
|
+PKG_LICENSE_FILES:=COPYING.LESSER
|
|
20
|
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+$(call include_mk, python-package.mk)
|
|
24
|
+
|
|
25
|
+define Package/python-gmpy2
|
|
26
|
+ SECTION:=lang
|
|
27
|
+ CATEGORY:=Languages
|
|
28
|
+ SUBMENU:=Python
|
|
29
|
+ TITLE:=python-gmpy2
|
|
30
|
+ URL:=http://code.google.com/p/gmpy/
|
|
31
|
+ DEPENDS:=+libgmp +python-light
|
|
32
|
+endef
|
|
33
|
+
|
|
34
|
+define Package/python-gmpy2/description
|
|
35
|
+gmpy2 is a C-coded Python extension module that supports multiple-precision
|
|
36
|
+arithmetic. gmpy2 is the successor to the original gmpy module. The gmpy module
|
|
37
|
+only supported the GMP multiple-precision library. gmpy2 adds support for the
|
|
38
|
+MPFR (correctly rounded real floating-point arithmetic) and MPC (correctly
|
|
39
|
+rounded complex floating-point arithmetic) libraries. gmpy2 also updates the
|
|
40
|
+API and naming conventions to be more consistent and support the additional
|
|
41
|
+functionality.
|
|
42
|
+endef
|
|
43
|
+
|
|
44
|
+define Build/Compile
|
|
45
|
+ $(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)" --nompfr)
|
|
46
|
+endef
|
|
47
|
+
|
|
48
|
+$(eval $(call PyPackage,python-gmpy2))
|
|
49
|
+$(eval $(call BuildPackage,python-gmpy2))
|