浏览代码

libsndfile: import from packages

Peter Wagner 10 年前
父节点
当前提交
aa69fde536
共有 2 个文件被更改,包括 74 次插入0 次删除
  1. 64
    0
      libs/libsndfile/Makefile
  2. 10
    0
      libs/libsndfile/patches/001-automake-compat.patch

+ 64
- 0
libs/libsndfile/Makefile 查看文件

@@ -0,0 +1,64 @@
1
+#
2
+# Copyright (C) 2007-2010 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libsndfile
11
+PKG_VERSION:=1.0.25
12
+PKG_RELEASE:=2
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://www.mega-nerd.com/libsndfile/files/
16
+PKG_MD5SUM:=e2b7bb637e01022c7d20f95f9c3990a2
17
+
18
+PKG_LICENSE:=LGPLv2.1
19
+PKG_LICENSE_FILES:=COPYING
20
+
21
+PKG_FIXUP:=autoreconf
22
+PKG_INSTALL:=1
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/libsndfile
27
+  SECTION:=libs
28
+  CATEGORY:=Libraries
29
+  TITLE:=Library for reading/writing audio files
30
+  URL:=http://www.mega-nerd.com/libsndfile/
31
+  DEPENDS:=@!avr32
32
+endef
33
+
34
+define Package/libsndfile/description
35
+ libsndfile is a library of C routines for reading and writing files
36
+ containing sampled audio data.
37
+endef
38
+
39
+CONFIGURE_ARGS+= \
40
+	--disable-alsa \
41
+	--disable-external-libs \
42
+	--disable-sqlite
43
+
44
+CONFIGURE_VARS += \
45
+	ac_cv_sys_file_offset_bits=64 \
46
+	ac_cv_sys_large_files=yes \
47
+	ac_cv_sys_largefile_CFLAGS=-D_LARGFILE_SOURCE \
48
+	ac_cv_sys_largefile_LDFLAGS= \
49
+	ac_cv_sys_largefile_LIBS= \
50
+	ac_cv_sys_largefile_source=yes
51
+
52
+TARGET_CFLAGS += $(FPIC)
53
+
54
+define Build/InstallDev
55
+	$(INSTALL_DIR) $(1)
56
+	$(CP) $(PKG_INSTALL_DIR)/* $(1)/
57
+endef
58
+
59
+define Package/libsndfile/install
60
+	$(INSTALL_DIR) $(1)/usr/lib
61
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsndfile.so.* $(1)/usr/lib/
62
+endef
63
+
64
+$(eval $(call BuildPackage,libsndfile))

+ 10
- 0
libs/libsndfile/patches/001-automake-compat.patch 查看文件

@@ -0,0 +1,10 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -1,5 +1,7 @@
4
+ ## Process this file with automake to produce Makefile.in
5
+ 
6
++ACLOCAL_AMFLAGS = -I M4
7
++
8
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gcc-werror
9
+ 
10
+ if BUILD_OCTAVE_MOD