Browse Source

sumo: add new package

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 10 years ago
parent
commit
aae3d2c9a0
2 changed files with 66 additions and 0 deletions
  1. 60
    0
      utils/sumo/Makefile
  2. 6
    0
      utils/sumo/files/sumo.sh

+ 60
- 0
utils/sumo/Makefile View File

@@ -0,0 +1,60 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=sumo
11
+PKG_VERSION:=0.22.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=@SF/sumo
16
+PKG_MD5SUM:=d239a3f94fdb905fdaf1648f2b71fd42
17
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
18
+
19
+PKG_LICENSE:=GPL-3.0
20
+PKG_LICENSE_FILES:=COPYING
21
+
22
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+CONFIGURE_ARGS += \
28
+	--with-xerces-includes=$(STAGING_DIR)/usr/include/xercesc \
29
+	--disable-debug \
30
+	--disable-dependency-tracking \
31
+	--disable-silent-rules
32
+
33
+define Package/sumo
34
+  SECTION:=utils
35
+  CATEGORY:=Utilities
36
+  TITLE:=SUMO - Simulation of Urban MObility
37
+  URL:=http://sumo-sim.org/
38
+  DEPENDS:=+libstdcpp +libxerces-c
39
+endef
40
+
41
+define Package/sumo/description
42
+  SUMO is a free and open traffic simulation suite which is available since 2001.
43
+  SUMO allows modelling of intermodal traffic systems including road vehicles,
44
+  public transport and pedestrians. Included with SUMO is a wealth of supporting
45
+  tools which handle tasks such as route finding, visualization, network import
46
+  and emission calculation. SUMO can be enhanced with custom models and provides
47
+  various APIs to remotely control the simulation.
48
+endef
49
+
50
+define Package/sumo/install
51
+	$(INSTALL_DIR) $(1)/usr/bin
52
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{activitygen,dfrouter,duarouter,emissionsDrivingCycle,emissionsMap,jtrrouter,marouter,netconvert,netgenerate,od2trips,polyconvert,TraCITestClient} $(1)/usr/bin
53
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sumo $(1)/usr/bin/sumo-bin
54
+	$(INSTALL_DIR) $(1)/usr/sbin
55
+	$(INSTALL_BIN) files/sumo.sh $(1)/usr/sbin/sumo
56
+	$(INSTALL_DIR) $(1)/usr/share/sumo
57
+	$(CP) $(PKG_BUILD_DIR)/data $(1)/usr/share/sumo/
58
+endef
59
+
60
+$(eval $(call BuildPackage,sumo))

+ 6
- 0
utils/sumo/files/sumo.sh View File

@@ -0,0 +1,6 @@
1
+#!/bin/sh
2
+# Copyright (C) 2015 OpenWrt.org
3
+
4
+SUMO_HOME=/usr/share/sumo sumo-bin $@
5
+
6
+exit 0