瀏覽代碼

Merge pull request #643 from mstorchak/misc-fixes

Update some packages, mostly license info
Steven Barth 10 年之前
父節點
當前提交
bbb7eb2b0c

+ 4
- 3
lang/luaposix/Makefile 查看文件

@@ -8,17 +8,18 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=luaposix
11
-PKG_VERSION:=v32
11
+PKG_VERSION:=v33.0.0
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=release-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=https://github.com/luaposix/luaposix/archive/
16
-PKG_MD5SUM:=2bfede7b7cee96c5d0f6c0354e17498c
16
+PKG_MD5SUM:=3241c33566542b7563ae001112646af6
17 17
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-release-$(PKG_VERSION)
18 18
 PKG_REMOVE_FILES:=aclocal.m4
19 19
 PKG_FIXUP:=autoreconf
20 20
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
21 21
 PKG_LICENSE:=MIT
22
+PKG_LICENSE_FILES:=COPYING
22 23
 
23 24
 include $(INCLUDE_DIR)/package.mk
24 25
 
@@ -48,7 +49,7 @@ endif
48 49
 
49 50
 define Package/luaposix/install
50 51
 	$(INSTALL_DIR) $(1)/usr/lib/lua
51
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ext/posix/.libs/posix_c.so $(1)/usr/lib/lua
52
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/ext/posix/.libs/posix.so $(1)/usr/lib/lua
52 53
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/posix.lua $(1)/usr/lib/lua
53 54
 endef
54 55
 

+ 20
- 19
lang/luaposix/patches/100-eglibc-compat.patch 查看文件

@@ -1,28 +1,29 @@
1
---- a/ext/posix/posix.c
2
-+++ b/ext/posix/posix.c
3
-@@ -1970,6 +1970,7 @@ static int Pctermid(lua_State *L)
4
- 	return 1;
5
- }
1
+diff -Naur luaposix-release-v33.0.0.orig/ext/posix/unistd.c luaposix-release-v33.0.0/ext/posix/unistd.c
2
+--- luaposix-release-v33.0.0.orig/ext/posix/unistd.c	2014-11-04 17:49:35.000000000 +0200
3
++++ luaposix-release-v33.0.0/ext/posix/unistd.c	2014-12-14 00:59:14.878622722 +0200
4
+@@ -526,6 +526,7 @@
5
+ #endif
6
+ 
6 7
  
7 8
 +#ifndef NO_GETLOGIN
8 9
  /***
9 10
  Current logged-in user.
10
- @see getlogin(3)
11
-@@ -1980,6 +1981,7 @@ static int Pgetlogin(lua_State *L)
12
- 	lua_pushstring(L, getlogin());
13
- 	return 1;
11
+ @treturn[1] string username, if successful
12
+@@ -538,6 +539,7 @@
13
+ 	checknargs(L, 0);
14
+ 	return pushstringresult(getlogin());
14 15
  }
15 16
 +#endif
16 17
  
17
- static void Fgetpasswd(lua_State *L, int i, const void *data)
18
- {
19
-@@ -3786,7 +3788,9 @@ static const luaL_Reg R[] =
20
- #if _POSIX_VERSION >= 200112L
21
- 	MENTRY( Pgetgroups	),
22
- #endif
18
+ 
19
+ /***
20
+@@ -1037,7 +1039,9 @@
21
+ 	LPOSIX_FUNC( Pgetegid		),
22
+ 	LPOSIX_FUNC( Pgeteuid		),
23
+ 	LPOSIX_FUNC( Pgetgid		),
23 24
 +#ifndef NO_GETLOGIN
24
- 	MENTRY( Pgetlogin	),
25
+ 	LPOSIX_FUNC( Pgetlogin		),
25 26
 +#endif
26
- 	MENTRY( Pgetopt		),
27
- 	MENTRY( Pgetpasswd	),
28
- 	MENTRY( Pgetpid		),
27
+ 	LPOSIX_FUNC( Pgetpgrp		),
28
+ 	LPOSIX_FUNC( Pgetpid		),
29
+ 	LPOSIX_FUNC( Pgetppid		),

+ 30
- 0
lang/luaposix/patches/101-disable-curses.patch 查看文件

@@ -0,0 +1,30 @@
1
+diff -Naur luaposix-release-v33.0.0.orig/ext/posix/posix.c luaposix-release-v33.0.0/ext/posix/posix.c
2
+--- luaposix-release-v33.0.0.orig/ext/posix/posix.c	2014-11-04 17:49:35.000000000 +0200
3
++++ luaposix-release-v33.0.0/ext/posix/posix.c	2014-12-14 01:49:44.486562194 +0200
4
+@@ -11,7 +11,6 @@
5
+  */
6
+ 
7
+ #include "ctype.c"
8
+-#include "curses.c"
9
+ #include "dirent.c"
10
+ #include "errno.c"
11
+ #include "fcntl.c"
12
+diff -Naur luaposix-release-v33.0.0.orig/configure.ac luaposix-release-v33.0.0/configure.ac
13
+--- luaposix-release-v33.0.0.orig/configure.ac	2014-11-04 17:49:35.000000000 +0200
14
++++ luaposix-release-v33.0.0/configure.ac	2014-12-14 01:58:08.214554482 +0200
15
+@@ -109,15 +109,6 @@
16
+   AC_SUBST([LIBRT], [-lrt])
17
+ fi
18
+ 
19
+-dnl Curses
20
+-AX_WITH_CURSES
21
+-AC_ARG_VAR(CURSES_LIB, [linker flags for curses library])
22
+-
23
+-save_LIBS=$LIBS
24
+-LIBS="$CURSES_LIB $LIBS"
25
+-AC_CHECK_FUNCS([resizeterm])
26
+-LIBS=$save_LIBS
27
+-
28
+ dnl Lua 5.1 or 5.2
29
+ AX_PROG_LUA(5.1, 5.3)
30
+ AX_LUA_HEADERS

+ 1
- 2
net/rsync/Makefile 查看文件

@@ -14,10 +14,9 @@ PKG_RELEASE:=1
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync/src
16 16
 PKG_MD5SUM:=43bd6676f0b404326eee2d63be3cdcfe
17
-PKG_LICENSE:=GPL-3.0
18
-PKG_LICENSE_FILES:=COPYING
19 17
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
20 18
 PKG_LICENSE:=GPL-3.0
19
+PKG_LICENSE_FILES:=COPYING
21 20
 
22 21
 PKG_INSTALL:=1
23 22
 PKG_BUILD_PARALLEL:=1

+ 2
- 2
net/tgt/Makefile 查看文件

@@ -7,8 +7,8 @@
7 7
 include $(TOPDIR)/rules.mk
8 8
 
9 9
 PKG_NAME:=tgt
10
-PKG_VERSION:=1.0.48
11
-PKG_REV:=22d9567f39e5eb8a794ce2cb5a2190abdbecaa1f
10
+PKG_VERSION:=1.0.53
11
+PKG_REV:=9764e0afd9a7115e356fc85569a780f9003c4eac
12 12
 PKG_RELEASE:=1
13 13
 PKG_USE_MIPS16:=0
14 14
 

+ 1
- 0
net/wget/Makefile 查看文件

@@ -16,6 +16,7 @@ PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
16 16
 PKG_MD5SUM:=78942cc0cce0a23e18114d982789e360
17 17
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
18 18
 PKG_LICENSE:=GPL-3.0+
19
+PKG_LICENSE_FILES:=COPYING
19 20
 
20 21
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
21 22
 

+ 3
- 2
utils/acl/Makefile 查看文件

@@ -8,8 +8,8 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=acl
11
-PKG_REV:=f2a5f57a20ffa007abc1fa24df1f76e18b74a425
12
-PKG_VERSION:=20140610
11
+PKG_REV:=62ce6354ef5a8eb5644908748f79c8cd18474d4c
12
+PKG_VERSION:=20140812
13 13
 PKG_RELEASE:=1
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -21,6 +21,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
21 21
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
22 22
 PKG_INSTALL:=1
23 23
 PKG_LICENSE:=LGPL-2.1 GPL-2.0
24
+PKG_LICENSE_FILES:=doc/COPYING doc/COPYING.LGPL
24 25
 
25 26
 include $(INCLUDE_DIR)/package.mk
26 27
 

+ 3
- 2
utils/attr/Makefile 查看文件

@@ -8,8 +8,8 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=attr
11
-PKG_REV:=50fc862d69984089ce09138b3350ee7762290403
12
-PKG_VERSION:=20140610
11
+PKG_REV:=c4a7fdbcc109d6e8b465a427c714926fcb85c750
12
+PKG_VERSION:=20141020
13 13
 PKG_RELEASE:=1
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -21,6 +21,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
21 21
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
22 22
 PKG_INSTALL:=1
23 23
 PKG_LICENSE:=LGPL-2.1 GPL-2.0
24
+PKG_LICENSE_FILES:=doc/COPYING doc/COPYING.LGPL
24 25
 
25 26
 include $(INCLUDE_DIR)/package.mk
26 27
 

+ 1
- 0
utils/haserl/Makefile 查看文件

@@ -16,6 +16,7 @@ PKG_SOURCE_URL:=@SF/haserl
16 16
 PKG_MD5SUM:=a9decddb508944d56f71dd2f821e2ec5
17 17
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
18 18
 PKG_LICENSE:=GPL-2.0
19
+PKG_LICENSE_FILES:=COPYING
19 20
 
20 21
 PKG_CONFIG_DEPENDS:= \
21 22
 	CONFIG_HASERL_with_lua \

+ 2
- 0
utils/lsof/Makefile 查看文件

@@ -17,6 +17,8 @@ PKG_SOURCE_URL:=http://ftp2.de.debian.org/debian/pool/main/l/lsof
17 17
 PKG_MD5SUM:=23420509564a897b76055f9d84d19068
18 18
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)+dfsg.orig
19 19
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
20
+PKG_LICENSE:=Unique
21
+PKG_LICENSE_FILES:=00README
20 22
 
21 23
 include $(INCLUDE_DIR)/package.mk
22 24
 

+ 1
- 0
utils/smartmontools/Makefile 查看文件

@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=@SF/smartmontools
17 17
 PKG_MD5SUM:=2ea0c62206e110192a97b59291b17f54
18 18
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
19 19
 PKG_LICENSE:=GPL-2.0+
20
+PKG_LICENSE_FILES:=COPYING
20 21
 
21 22
 include $(INCLUDE_DIR)/package.mk
22 23
 

+ 1
- 0
utils/tmux/Makefile 查看文件

@@ -16,6 +16,7 @@ PKG_SOURCE_URL:=@SF/tmux
16 16
 PKG_MD5SUM:=b07601711f96f1d260b390513b509a2d
17 17
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
18 18
 PKG_LICENSE:=ISC
19
+PKG_LICENSE_FILES:=COPYING
19 20
 
20 21
 PKG_INSTALL:=1
21 22