|
@@ -1,17 +1,17 @@
|
1
|
1
|
--- a/src/Makefile.in
|
2
|
2
|
+++ b/src/Makefile.in
|
3
|
|
-@@ -7742,7 +7742,7 @@ cache_cf.o: cf_parser.cci
|
|
3
|
+@@ -7759,7 +7759,7 @@ cache_cf.o: cf_parser.cci
|
4
|
4
|
|
5
|
5
|
# cf_gen builds the configuration files.
|
6
|
6
|
cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
|
7
|
|
-- $(HOSTCXX) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
|
7
|
+- $(BUILDCXX) $(BUILDCXXFLAGS) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
8
|
8
|
+ g++ -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
9
|
9
|
|
10
|
10
|
# squid.conf.default is built by cf_gen when making cf_parser.cci
|
11
|
11
|
squid.conf.default squid.conf.documented: cf_parser.cci
|
12
|
12
|
--- a/configure
|
13
|
13
|
+++ b/configure
|
14
|
|
-@@ -22226,7 +22226,7 @@ $as_echo_n "checking whether the SSL_get
|
|
14
|
+@@ -22935,7 +22935,7 @@ $as_echo_n "checking whether the SSL_get
|
15
|
15
|
if test "$cross_compiling" = yes; then :
|
16
|
16
|
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
17
|
17
|
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
|
@@ -20,7 +20,7 @@
|
20
|
20
|
See \`config.log' for more details" "$LINENO" 5; }
|
21
|
21
|
else
|
22
|
22
|
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
23
|
|
-@@ -22274,7 +22274,7 @@ $as_echo_n "checking whether the workaro
|
|
23
|
+@@ -22983,7 +22983,7 @@ $as_echo_n "checking whether the workaro
|
24
|
24
|
if test "$cross_compiling" = yes; then :
|
25
|
25
|
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
26
|
26
|
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
|
@@ -29,7 +29,7 @@
|
29
|
29
|
See \`config.log' for more details" "$LINENO" 5; }
|
30
|
30
|
else
|
31
|
31
|
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
32
|
|
-@@ -24924,7 +24924,7 @@ else
|
|
32
|
+@@ -28201,7 +28201,7 @@ else
|
33
|
33
|
if test "$cross_compiling" = yes; then :
|
34
|
34
|
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
35
|
35
|
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
|
@@ -38,7 +38,7 @@
|
38
|
38
|
See \`config.log' for more details" "$LINENO" 5; }
|
39
|
39
|
else
|
40
|
40
|
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
41
|
|
-@@ -24949,7 +24949,7 @@ else
|
|
41
|
+@@ -28226,7 +28226,7 @@ else
|
42
|
42
|
if test "$cross_compiling" = yes; then :
|
43
|
43
|
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
44
|
44
|
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|