Kaynağa Gözat

squid: update to 3.5.2

Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
Marko Ratkaj 10 yıl önce
ebeveyn
işleme
c05980909c

+ 4
- 4
net/squid/Makefile Dosyayı Görüntüle

@@ -8,15 +8,15 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=squid
11
-PKG_VERSION:=3.4.11
11
+PKG_VERSION:=3.5.2
12 12
 PKG_RELEASE:=2
13 13
 
14 14
 PKG_LICENSE:=GPL-2.0
15 15
 PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
16 16
 
17 17
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
18
-PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v3/3.4/
19
-PKG_MD5SUM:=e79ddb108d24823da8c1dbc0fc4a31fb
18
+PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v3/3.5/
19
+PKG_MD5SUM:=0330ec9f69e333c2a81fa4502ba96a22
20 20
 
21 21
 PKG_BUILD_PARALLEL:=1
22 22
 PKG_INSTALL:=1
@@ -33,7 +33,7 @@ endef
33 33
 define Package/squid
34 34
   $(call Package/squid/Default)
35 35
   MENU:=1
36
-  DEPENDS:=+libopenssl +libpthread +librt +libltdl +libstdcpp
36
+  DEPENDS:=+libopenssl +libpthread +librt +libltdl +libstdcpp +libgnutls
37 37
   TITLE:=full-featured Web proxy cache
38 38
 endef
39 39
 

+ 6
- 6
net/squid/patches/001-cross_compile.patch Dosyayı Görüntüle

@@ -1,17 +1,17 @@
1 1
 --- a/src/Makefile.in
2 2
 +++ b/src/Makefile.in
3
-@@ -7742,7 +7742,7 @@ cache_cf.o: cf_parser.cci
3
+@@ -7759,7 +7759,7 @@ cache_cf.o: cf_parser.cci
4 4
  
5 5
  # cf_gen builds the configuration files.
6 6
  cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
7
--	$(HOSTCXX) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
7
+-	$(BUILDCXX) $(BUILDCXXFLAGS) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
8 8
 +	g++ -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
9 9
  
10 10
  # squid.conf.default is built by cf_gen when making cf_parser.cci
11 11
  squid.conf.default squid.conf.documented: cf_parser.cci
12 12
 --- a/configure
13 13
 +++ b/configure
14
-@@ -22226,7 +22226,7 @@ $as_echo_n "checking whether the SSL_get
14
+@@ -22935,7 +22935,7 @@ $as_echo_n "checking whether the SSL_get
15 15
    if test "$cross_compiling" = yes; then :
16 16
    { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
17 17
  $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
@@ -20,7 +20,7 @@
20 20
  See \`config.log' for more details" "$LINENO" 5; }
21 21
  else
22 22
    cat confdefs.h - <<_ACEOF >conftest.$ac_ext
23
-@@ -22274,7 +22274,7 @@ $as_echo_n "checking whether the workaro
23
+@@ -22983,7 +22983,7 @@ $as_echo_n "checking whether the workaro
24 24
    if test "$cross_compiling" = yes; then :
25 25
    { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
26 26
  $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
@@ -29,7 +29,7 @@
29 29
  See \`config.log' for more details" "$LINENO" 5; }
30 30
  else
31 31
    cat confdefs.h - <<_ACEOF >conftest.$ac_ext
32
-@@ -24924,7 +24924,7 @@ else
32
+@@ -28201,7 +28201,7 @@ else
33 33
      if test "$cross_compiling" = yes; then :
34 34
    { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
35 35
  $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
@@ -38,7 +38,7 @@
38 38
  See \`config.log' for more details" "$LINENO" 5; }
39 39
  else
40 40
    cat confdefs.h - <<_ACEOF >conftest.$ac_ext
41
-@@ -24949,7 +24949,7 @@ else
41
+@@ -28226,7 +28226,7 @@ else
42 42
      if test "$cross_compiling" = yes; then :
43 43
    { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
44 44
  $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}

+ 13
- 12
net/squid/patches/100-mime.patch Dosyayı Görüntüle

@@ -1,29 +1,30 @@
1 1
 --- a/src/mime.conf.default
2 2
 +++ b/src/mime.conf.default
3
-@@ -1,19 +1,3 @@
4
--# This file associates filename extensions (for servers or services
5
--# that don't automatically include them - like ftp) with a mime type
6
--# and a graphical icon.
7
--#
8
--#
9
--# This file has the format :
10
--# regex content-type icon content-encoding transfer-mode
11
--#-----------------------------------------------------------------------------------
3
+@@ -1,20 +1,3 @@
4
+-## Copyright (C) 1996-2015 The Squid Software Foundation and contributors
5
+-##
6
+-## Squid software is distributed under GPLv2+ license and includes
7
+-## contributions from numerous individuals and organizations.
8
+-## Please see the COPYING and CONTRIBUTORS files for details.
9
+-##
12 10
 -#
11
+-# This file associates URL patterns for servers or services
12
+-# that don't automatically include Content-Type (like ftp) with a mime type
13
+-# and a graphical icon.
13 14
 -#
14 15
 -# Content-Encodings are taken from section 3.1 of RFC2068 (HTTP/1.1)
15 16
 -#
16
--#
17
+-# This file has the format :
17 18
 -#
18 19
 -# regexp	content-type			icon				encoding mode	actions
19 20
 -#--------------------------------------------------------------------------------------------------------
20 21
  \.gif$			image/gif		silk/image.png			-	image	+download
21 22
  \.mime$			www/mime		silk/page_white_text.png	-	ascii	+download
22 23
  ^internal-dirup$	-			silk/arrow_up.png		-	-
23
-@@ -190,6 +174,4 @@ README		text/plain			silk/information.pn
24
+@@ -191,6 +174,4 @@ README		text/plain			silk/information.pn
24 25
  \.xml$		text/xml			silk/page_world.png		-	ascii	+download
25 26
  \.xsl$		text/xml			silk/layout.png			-	ascii	+download
26 27
  \.xyz$		chemical/x-xyz			silk/chart_line.png		-	image	+download
27
--
28
+-#
28 29
 -# the default
29 30
  .		text/plain			silk/bullet_red.png		-	image	+download +view