Browse Source

Merge pull request #1408 from jow-/screen-musl-compat

screen: fix musl compatibility
Jo-Philipp Wich 9 years ago
parent
commit
d379979793
2 changed files with 12 additions and 2 deletions
  1. 2
    2
      utils/screen/Makefile
  2. 10
    0
      utils/screen/patches/200-musl-compat.patch

+ 2
- 2
utils/screen/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2014 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=screen
11 11
 PKG_VERSION:=4.2.1
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@GNU/screen

+ 10
- 0
utils/screen/patches/200-musl-compat.patch View File

@@ -0,0 +1,10 @@
1
+--- a/utmp.c
2
++++ b/utmp.c
3
+@@ -33,6 +33,7 @@
4
+ #include "config.h"
5
+ #include "screen.h"
6
+ #include "extern.h"
7
++#include "os.h"
8
+ 
9
+ #ifdef HAVE_UTEMPTER
10
+ #include <utempter.h>