소스 검색

libpam: fix build.

 - Update PKG_MD5SUM.
 - Update PKG_RELEASE.
 - Update patch 0001- to always use /lib directory.
 - Refresh other patches.

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Yousong Zhou 9 년 전
부모
커밋
d5697f6a95

+ 2
- 2
libs/libpam/Makefile 파일 보기

@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libpam
11 11
 PKG_VERSION:=1.2.0
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=Linux-PAM-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=http://www.linux-pam.org/library/
16
-PKG_MD5SUM:=35b6091af95981b1b2cd60d813b5e4ee
16
+PKG_MD5SUM:=ee4a480d77b341c99e8b1375f8f180c0
17 17
 PKG_INSTALL:=1
18 18
 PKG_FIXUP:=autoreconf
19 19
 PKG_MAINTAINER:=Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>

+ 36
- 0
libs/libpam/patches/0001-build-always-use-lib-instead-of-lib64.patch 파일 보기

@@ -0,0 +1,36 @@
1
+From 1948dd03d69c1a50e92d7e8868b7d6eabd4873c1 Mon Sep 17 00:00:00 2001
2
+From: Yousong Zhou <yszhou4tech@gmail.com>
3
+Date: Wed, 17 Jun 2015 16:11:31 +0800
4
+Subject: [PATCH 1/7] build: always use /lib instead of /lib64.
5
+
6
+* configure.ac: OpenWrt does not use /lib64.
7
+
8
+Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
9
+---
10
+ configure.ac |   10 +---------
11
+ 1 file changed, 1 insertion(+), 9 deletions(-)
12
+
13
+diff --git a/configure.ac b/configure.ac
14
+index fd0e310..306b6e2 100644
15
+--- a/configure.ac
16
++++ b/configure.ac
17
+@@ -25,15 +25,7 @@ dnl If we use /usr as prefix, use /etc for config files
18
+         then
19
+                 sysconfdir="/etc"
20
+         fi
21
+-	if test ${libdir} = '${exec_prefix}/lib'
22
+-	then
23
+-		case "`uname -m`" in
24
+-		    x86_64|ppc64|s390x|sparc64)
25
+-			libdir="/lib64" ;;
26
+-		    *)
27
+-			libdir="/lib" ;;
28
+-		esac
29
+-	fi
30
++	libdir="/lib"
31
+ 	if test ${sbindir} = '${exec_prefix}/sbin'
32
+         then
33
+                 sbindir="/sbin"
34
+-- 
35
+1.7.10.4
36
+

+ 0
- 27
libs/libpam/patches/0001-build-use-host_cpu-for-lib64-directory-handling.patch 파일 보기

@@ -1,28 +0,0 @@
1
-From ee916fd0ec70eb37a97da29f6ec0c26bef7cf6f2 Mon Sep 17 00:00:00 2001
2
-From: Yousong Zhou <yszhou4tech@gmail.com>
3
-Date: Wed, 17 Jun 2015 16:11:31 +0800
4
-Subject: [PATCH 1/7] build: use $host_cpu for lib64 directory handling.
5
-
6
-* configure.ac: use $host_cpu for lib64 directory handling.
7
-
8
-Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
9
----
10
- configure.ac |    2 +-
11
- 1 file changed, 1 insertion(+), 1 deletion(-)
12
-
13
-diff --git a/configure.ac b/configure.ac
14
-index fd0e310..1bc2591 100644
15
---- a/configure.ac
16
-+++ b/configure.ac
17
-@@ -27,7 +27,7 @@ dnl If we use /usr as prefix, use /etc for config files
18
-         fi
19
- 	if test ${libdir} = '${exec_prefix}/lib'
20
- 	then
21
--		case "`uname -m`" in
22
-+		case "$host_cpu" in
23
- 		    x86_64|ppc64|s390x|sparc64)
24
- 			libdir="/lib64" ;;
25
- 		    *)
26
-1.7.10.4
27
-

+ 3
- 3
libs/libpam/patches/0002-build-ignore-pam_rhosts-if-neither-ruserok-nor-ruser.patch 파일 보기

@@ -1,4 +1,4 @@
1
-From e985c1ef2c739a597b2d7a2efc3c310c02e40c1f Mon Sep 17 00:00:00 2001
1
+From 1a2e6c979118dce5e79604e88c008c7879d1e4e6 Mon Sep 17 00:00:00 2001
2 2
 From: Yousong Zhou <yszhou4tech@gmail.com>
3 3
 Date: Wed, 17 Jun 2015 18:19:23 +0800
4 4
 Subject: [PATCH 2/7] build: ignore pam_rhosts if neither ruserok nor
@@ -16,10 +16,10 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
16 16
  3 files changed, 13 insertions(+), 4 deletions(-)
17 17
 
18 18
 diff --git a/configure.ac b/configure.ac
19
-index 1bc2591..3c4d8bb 100644
19
+index 306b6e2..084071a 100644
20 20
 --- a/configure.ac
21 21
 +++ b/configure.ac
22
-@@ -542,7 +542,10 @@ AC_CHECK_FUNCS(fseeko getdomainname gethostname gettimeofday lckpwdf mkdir selec
22
+@@ -534,7 +534,10 @@ AC_CHECK_FUNCS(fseeko getdomainname gethostname gettimeofday lckpwdf mkdir selec
23 23
  AC_CHECK_FUNCS(strcspn strdup strspn strstr strtol uname)
24 24
  AC_CHECK_FUNCS(getutent_r getpwnam_r getpwuid_r getgrnam_r getgrgid_r getspnam_r)
25 25
  AC_CHECK_FUNCS(getgrouplist getline getdelim)

+ 3
- 3
libs/libpam/patches/0003-build-ignore-pam_lastlog-when-logwtmp-is-not-availab.patch 파일 보기

@@ -1,4 +1,4 @@
1
-From 173164996ca7daf3fa705f2a0bb2991b0d5d2083 Mon Sep 17 00:00:00 2001
1
+From bac1ee3033cf22e31730fe3e77ca82bd5ebba692 Mon Sep 17 00:00:00 2001
2 2
 From: Yousong Zhou <yszhou4tech@gmail.com>
3 3
 Date: Wed, 17 Jun 2015 21:18:05 +0800
4 4
 Subject: [PATCH 3/7] build: ignore pam_lastlog when logwtmp is not available.
@@ -13,10 +13,10 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
13 13
  2 files changed, 8 insertions(+), 2 deletions(-)
14 14
 
15 15
 diff --git a/configure.ac b/configure.ac
16
-index 3c4d8bb..8de6edf 100644
16
+index 084071a..ca4bf5b 100644
17 17
 --- a/configure.ac
18 18
 +++ b/configure.ac
19
-@@ -544,8 +544,10 @@ AC_CHECK_FUNCS(getutent_r getpwnam_r getpwuid_r getgrnam_r getgrgid_r getspnam_r
19
+@@ -536,8 +536,10 @@ AC_CHECK_FUNCS(getutent_r getpwnam_r getpwuid_r getgrnam_r getgrgid_r getspnam_r
20 20
  AC_CHECK_FUNCS(getgrouplist getline getdelim)
21 21
  AC_CHECK_FUNCS(inet_ntop inet_pton innetgr)
22 22
  AC_CHECK_FUNCS([ruserok_af ruserok], [break])

+ 3
- 3
libs/libpam/patches/0004-build-fix-build-when-crypt-is-not-part-of-crypt_libs.patch 파일 보기

@@ -1,4 +1,4 @@
1
-From 20e5efe4b2a8471bc52e480e53cff68a4de19c56 Mon Sep 17 00:00:00 2001
1
+From a35daea1b8be768d1b0be6eae157fbf3e5380f92 Mon Sep 17 00:00:00 2001
2 2
 From: Yousong Zhou <yszhou4tech@gmail.com>
3 3
 Date: Wed, 17 Jun 2015 18:22:31 +0800
4 4
 Subject: [PATCH 4/7] build: fix build when crypt() is not part of crypt_libs.
@@ -11,10 +11,10 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
11 11
  1 file changed, 1 insertion(+), 1 deletion(-)
12 12
 
13 13
 diff --git a/configure.ac b/configure.ac
14
-index 8de6edf..c15441b 100644
14
+index ca4bf5b..6553c78 100644
15 15
 --- a/configure.ac
16 16
 +++ b/configure.ac
17
-@@ -416,7 +416,7 @@ AS_IF([test "x$ac_cv_header_xcrypt_h" = "xyes"],
17
+@@ -408,7 +408,7 @@ AS_IF([test "x$ac_cv_header_xcrypt_h" = "xyes"],
18 18
    [crypt_libs="crypt"])
19 19
  
20 20
  BACKUP_LIBS=$LIBS

+ 1
- 1
libs/libpam/patches/0005-build-fix-doc-build.patch 파일 보기

@@ -1,4 +1,4 @@
1
-From df7abf333d19aefd166f613b696345732ae4c9c8 Mon Sep 17 00:00:00 2001
1
+From 1563e57ea8ab9d123f765129a6840929ef58ff7a Mon Sep 17 00:00:00 2001
2 2
 From: Yousong Zhou <yszhou4tech@gmail.com>
3 3
 Date: Wed, 17 Jun 2015 20:38:41 +0800
4 4
 Subject: [PATCH 5/7] build: fix doc build.

+ 1
- 1
libs/libpam/patches/0006-pam_unix-fix-compilation-in-case-rpc-rpc.h-is-missin.patch 파일 보기

@@ -1,4 +1,4 @@
1
-From 596797ab7f46fb4d0338e75db7c0d1019cd4df87 Mon Sep 17 00:00:00 2001
1
+From 2e3ed4c6fb09f84fede589047d37d11783202d34 Mon Sep 17 00:00:00 2001
2 2
 From: Yousong Zhou <yszhou4tech@gmail.com>
3 3
 Date: Wed, 17 Jun 2015 18:16:18 +0800
4 4
 Subject: [PATCH 6/7] pam_unix: fix compilation in case rpc/rpc.h is missing.

+ 1
- 1
libs/libpam/patches/0007-Check-if-innetgr-is-available-at-compile-time.patch 파일 보기

@@ -1,4 +1,4 @@
1
-From 9e2fa22891a87592c1a04801623fea5be40cb581 Mon Sep 17 00:00:00 2001
1
+From c681bd104627139eac2f40fe303e1f67676233e8 Mon Sep 17 00:00:00 2001
2 2
 From: Yousong Zhou <yszhou4tech@gmail.com>
3 3
 Date: Wed, 17 Jun 2015 15:33:43 +0800
4 4
 Subject: [PATCH 7/7] Check if innetgr is available at compile time.