Browse Source

lttng-modules: add new package

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 years ago
parent
commit
dd313555f3
1 changed files with 45 additions and 0 deletions
  1. 45
    0
      devel/lttng-modules/Makefile

+ 45
- 0
devel/lttng-modules/Makefile View File

@@ -0,0 +1,45 @@
1
+#
2
+# Copyright (C) 2013-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=lttng-modules
11
+PKG_VERSION:=2.6.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
+PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)/
16
+PKG_MD5SUM:=a058ab037daaca293a54934d7b9f9c98
17
+
18
+PKG_LICENSE:=LGPL-2.1 GPL-2.0 MIT
19
+PKG_LICENSE_FILES:=LICENSE
20
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
21
+
22
+include $(INCLUDE_DIR)/kernel.mk
23
+include $(INCLUDE_DIR)/package.mk
24
+
25
+define KernelPackage/lttng
26
+  SUBMENU:=Other modules
27
+  TITLE:=Linux Trace Toolkit: next generation (kernel modules)
28
+  URL:=https://lttng.org/
29
+  DEPENDS:= @!TARGET_uml
30
+  FILES:= \
31
+	$(PKG_BUILD_DIR)/lttng-*.$(LINUX_KMOD_SUFFIX) \
32
+	$(PKG_BUILD_DIR)/lib/lttng-*.$(LINUX_KMOD_SUFFIX) \
33
+	$(PKG_BUILD_DIR)/probes/lttng-*.$(LINUX_KMOD_SUFFIX)
34
+endef
35
+
36
+define Build/Compile
37
+	$(MAKE) -C "$(LINUX_DIR)" \
38
+		ARCH="$(LINUX_KARCH)" \
39
+		CROSS_COMPILE="$(TARGET_CROSS)" \
40
+		SUBDIRS="$(PKG_BUILD_DIR)" \
41
+		V="$(V)" \
42
+		modules
43
+endef
44
+
45
+$(eval $(call KernelPackage,lttng))