Browse Source

Merge pull request #631 from commodo/python-dns-fix

Python dns fix
Steven Barth 10 years ago
parent
commit
e48f86749f
1 changed files with 10 additions and 8 deletions
  1. 10
    8
      lang/python-dns/Makefile

+ 10
- 8
lang/python-dns/Makefile View File

@@ -7,15 +7,16 @@
7 7
 
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10
-PKG_NAME:=dnspython
10
+PKG_NAME:=python-dns
11 11
 PKG_RELEASE:=1
12 12
 PKG_VERSION:=1.12.0
13 13
 PKG_SOURCE_URL:=http://www.dnspython.org/kits/$(PKG_VERSION)
14 14
 PKG_MD5SUM:=3f2601ef3c8b77fc6d21a9c77a81efeb
15
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE:=dnspython-$(PKG_VERSION).tar.gz
16 16
 PKG_MAINTAINER:=Denis Shulyaka <Shulyaka@gmail.com>
17 17
 PKG_LICENSE:=ISC
18 18
 PKG_LICENSE_FILES:=LICENSE
19
+PKG_BUILD_DIR:=$(BUILD_DIR)/dnspython-$(PKG_VERSION)
19 20
 
20 21
 include $(INCLUDE_DIR)/package.mk
21 22
 $(call include_mk, python-package.mk)
@@ -26,7 +27,7 @@ define Package/python-dns
26 27
 	SUBMENU:=Python
27 28
 	TITLE:=dnspython
28 29
 	URL:=http://www.dnspython.org/
29
-	DEPENDS:=+python-mini
30
+	DEPENDS:=+python
30 31
 endef
31 32
 
32 33
 define Package/python-dns/description
@@ -34,13 +35,14 @@ define Package/python-dns/description
34 35
 endef
35 36
 
36 37
 define Build/Compile
37
-	$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
38
+	$(call Build/Compile/PyMod,,\
39
+		install --prefix="$(PKG_INSTALL_DIR)/usr" \
40
+	)
38 41
 endef
39 42
 
40
-define Package/python-dns/install
41
-	$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
42
-	$(CP) $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/dns/* \
43
-		$(1)$(PYTHON_PKG_DIR)
43
+define PyPackage/python-dns/filespec
44
++|/usr/lib/python$(PYTHON_VERSION)/site-packages
44 45
 endef
45 46
 
47
+$(eval $(call PyPackage,python-dns))
46 48
 $(eval $(call BuildPackage,python-dns))