|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=ffmpeg
|
11
|
11
|
PKG_VERSION:=0.11.5
|
12
|
|
-PKG_RELEASE:=4
|
|
12
|
+PKG_RELEASE:=5
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
15
|
15
|
PKG_SOURCE_URL:=http://ffmpeg.org/releases/
|
|
@@ -300,7 +300,7 @@ endef
|
300
|
300
|
|
301
|
301
|
define Package/libffmpeg-custom
|
302
|
302
|
$(call Package/libffmpeg/Default)
|
303
|
|
- TITLE+= (mini)
|
|
303
|
+ TITLE+= (custom)
|
304
|
304
|
DEPENDS+= @DEVEL +libspeex
|
305
|
305
|
VARIANT:=custom
|
306
|
306
|
MENU:=1
|
|
@@ -465,6 +465,7 @@ ifeq ($(BUILD_VARIANT),mini)
|
465
|
465
|
--disable-ffplay \
|
466
|
466
|
--disable-ffprobe \
|
467
|
467
|
--disable-ffserver \
|
|
468
|
+ --disable-avdevice \
|
468
|
469
|
--disable-avfilter \
|
469
|
470
|
--disable-postproc \
|
470
|
471
|
--disable-swresample \
|
|
@@ -511,7 +512,15 @@ define Build/InstallDev/full
|
511
|
512
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swresample,swscale}.pc $(1)/usr/lib/pkgconfig/
|
512
|
513
|
endef
|
513
|
514
|
|
514
|
|
-Build/InstallDev/mini = $(Build/InstallDev/custom)
|
|
515
|
+define Build/InstallDev/mini
|
|
516
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
517
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/lib{avcodec,avformat,avutil} $(1)/usr/include/
|
|
518
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
519
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avformat,avutil}.{a,so*} $(1)/usr/lib/
|
|
520
|
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
521
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lib{avcodec,avformat,avutil}.pc $(1)/usr/lib/pkgconfig/
|
|
522
|
+endef
|
|
523
|
+
|
515
|
524
|
Build/InstallDev/audio-dec = $(Build/InstallDev/custom)
|
516
|
525
|
|
517
|
526
|
# XXX: attempt at installing "best" dev files available
|
|
@@ -563,7 +572,11 @@ define Package/libffmpeg-full/install
|
563
|
572
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swresample,swscale}.so.* $(1)/usr/lib/
|
564
|
573
|
endef
|
565
|
574
|
|
566
|
|
-Package/libffmpeg-mini/install = $(Package/libffmpeg-custom/install)
|
|
575
|
+define Package/libffmpeg-mini/install
|
|
576
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
577
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avformat,avutil}.so.* $(1)/usr/lib/
|
|
578
|
+endef
|
|
579
|
+
|
567
|
580
|
Package/libffmpeg-audio-dec/install = $(Package/libffmpeg-custom/install)
|
568
|
581
|
|
569
|
582
|
$(eval $(call BuildPackage,ffmpeg))
|