소스 검색

python: add missing host build dependency on expat/host

Since 94f87dc1, host build of Python depends on expat installed in host
staging directory. However, pyexpat extension fails to build if expat
was not built and installed to staging dir before - adding host build
dependency should fix this.

Signed-off-by: Jan Čermák <jan.cermak@nic.cz>
Jan Čermák 9 년 전
부모
커밋
3ac990447f
1개의 변경된 파일1개의 추가작업 그리고 1개의 파일을 삭제
  1. 1
    1
      lang/python/Makefile

+ 1
- 1
lang/python/Makefile 파일 보기

@@ -29,7 +29,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
29 29
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
30 30
 
31 31
 PKG_BUILD_DEPENDS:=python/host
32
-HOST_BUILD_DEPENDS:=bzip2/host
32
+HOST_BUILD_DEPENDS:=bzip2/host expat/host
33 33
 
34 34
 include $(INCLUDE_DIR)/host-build.mk
35 35
 include $(INCLUDE_DIR)/package.mk