Преглед на файлове

net: Import cifs-utils

Import cifs-utils from old packages:

* update to 6.4
* add upstream patch to fix builds with musl
* add license information
* add myself as maintainer

Signed-off-by: Florian Fainelli <florian@openwrt.org>
Florian Fainelli преди 9 години
родител
ревизия
89cce919ec
променени са 2 файла, в които са добавени 74 реда и са изтрити 0 реда
  1. 44
    0
      net/cifs-utils/Makefile
  2. 30
    0
      net/cifs-utils/patches/001-fix-musl-build.patch

+ 44
- 0
net/cifs-utils/Makefile Целия файл

@@ -0,0 +1,44 @@
1
+#
2
+# Copyright (C) 2007-2012 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=cifs-utils
11
+PKG_VERSION:=6.4
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://ftp.samba.org/pub/linux-cifs/cifs-utils
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
16
+PKG_MD5SUM:=b7d75b67fd3987952896d27256c7293d
17
+
18
+PKG_MAINTAINER:=Florian Fainelli <florian@openwrt.org>
19
+PKG_LICENSE:=GPL-3.0
20
+PKG_LICENSE_FILES:=COPYING
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+
24
+define Package/cifsmount
25
+  SECTION:=net
26
+  CATEGORY:=Network
27
+  TITLE:=CIFS mount utilities
28
+  URL:=http://wiki.samba.org/index.php/LinuxCIFS_utils
29
+endef
30
+
31
+TARGET_CFLAGS += -Wno-error
32
+
33
+CONFIGURE_ARGS += \
34
+	--exec-prefix=/usr \
35
+	--prefix=/ \
36
+	--with-libcap-ng=no \
37
+	--with-libcap=no
38
+
39
+define Package/cifsmount/install
40
+	$(INSTALL_DIR) $(1)/usr/sbin
41
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/mount.cifs $(1)/usr/sbin/
42
+endef
43
+
44
+$(eval $(call BuildPackage,cifsmount))

+ 30
- 0
net/cifs-utils/patches/001-fix-musl-build.patch Целия файл

@@ -0,0 +1,30 @@
1
+From 6603cef0f06c450196a1bca06bb143d8fcda5651 Mon Sep 17 00:00:00 2001
2
+From: Felix Janda <felix.janda@posteo.de>
3
+Date: Fri, 5 Dec 2014 23:19:29 +0100
4
+Subject: [PATCH 1/1] mtab.c: include <paths.h> for _PATH_MOUNTED
5
+MIME-Version: 1.0
6
+Content-Type: text/plain; charset=UTF-8
7
+Content-Transfer-Encoding: 8bit
8
+
9
+Backported from: 6603cef0f06c450196a1bca06bb143d8fcda5651
10
+
11
+Signed-off-by: Felix Janda <felix.janda@posteo.de>
12
+Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
13
+---
14
+ mtab.c | 1 +
15
+ 1 file changed, 1 insertion(+)
16
+
17
+diff --git a/mtab.c b/mtab.c
18
+index 7b365b3..a662a3c 100644
19
+--- a/mtab.c
20
++++ b/mtab.c
21
+@@ -38,6 +38,7 @@
22
+ #include <mntent.h>
23
+ #include <stdlib.h>
24
+ #include <signal.h>
25
++#include <paths.h>
26
+ #include "mount.h"
27
+ #include "config.h"
28
+ 
29
+-- 
30
+2.5.0