|
@@ -0,0 +1,44 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2007-2012 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=cifs-utils
|
|
11
|
+PKG_VERSION:=6.4
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE_URL:=http://ftp.samba.org/pub/linux-cifs/cifs-utils
|
|
15
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
16
|
+PKG_MD5SUM:=b7d75b67fd3987952896d27256c7293d
|
|
17
|
+
|
|
18
|
+PKG_MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
|
19
|
+PKG_LICENSE:=GPL-3.0
|
|
20
|
+PKG_LICENSE_FILES:=COPYING
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/cifsmount
|
|
25
|
+ SECTION:=net
|
|
26
|
+ CATEGORY:=Network
|
|
27
|
+ TITLE:=CIFS mount utilities
|
|
28
|
+ URL:=http://wiki.samba.org/index.php/LinuxCIFS_utils
|
|
29
|
+endef
|
|
30
|
+
|
|
31
|
+TARGET_CFLAGS += -Wno-error
|
|
32
|
+
|
|
33
|
+CONFIGURE_ARGS += \
|
|
34
|
+ --exec-prefix=/usr \
|
|
35
|
+ --prefix=/ \
|
|
36
|
+ --with-libcap-ng=no \
|
|
37
|
+ --with-libcap=no
|
|
38
|
+
|
|
39
|
+define Package/cifsmount/install
|
|
40
|
+ $(INSTALL_DIR) $(1)/usr/sbin
|
|
41
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount.cifs $(1)/usr/sbin/
|
|
42
|
+endef
|
|
43
|
+
|
|
44
|
+$(eval $(call BuildPackage,cifsmount))
|